Login loop / device not visible for Ubuntu 16.04 with 1080Ti -- CUDA 8.0

Hi,

I have a GTX 1080Ti. I’m facing login loop if I install CUDA 8.0 from the deb file.

If I use the run file instead, by switching off OpenGL libraries and saying no to X server, the device name is being shown as “ERR” on nvidia-smi. I wonder if there’s a bug with the NVIDIA 375 drivers. Need help.

So don’t use the deb file method.

Install the latest driver for your 1080Ti using the latest driver runfile installer for it obtained from:

www.nvidia.com/drivers

It should be a version like 381.09 or higher.

If you have properly installed CUDA 8 from the latest runfile installer (CUDA 8.0.61) then the only thing you should need to do is update your driver with the driver runfile installer.

This is not a bug per se. A given video card is not supported by all drivers that were ever created in the past. It is only supported by drivers that were released after the video card was released. In the case of CUDA 8.0.61, it was released before 1080Ti became available. So you have to use a newer driver than the one that comes with the 8.0.61 installer.

To avoid the Ubuntu login loop, you should follow the same method you previously found to avoid that, when you install a new driver.

How do I install the latest driver with OpenGL off? I get this error now.

predible@ava:~/Downloads$ sudo bash NVIDIA-Linux-x86_64-381.22.run --no-opengl-libs
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 381.22..........................................................
./nvidia-installer: unrecognized option: "--no-opengl-libs"

ERROR: Invalid commandline, please run `./nvidia-installer --help` for usage information.

The exact command line switch varies. Did you do what the output suggested:

ERROR: Invalid commandline, please run `./nvidia-installer --help` for usage information.

Please do that and find the option to get advanced options ( -A ?) and run it again to get the advanced options.

I think the command switch might be --no-opengl-files on a driver install

Hi,

–no-opengl-files for the driver works. Thanks!