[negativo17] Wayland vkCreateSwapchainKHR returns VK_ERROR_INITIALIZATION_FAILED

We’re trying to work out a possible mismatch between the official 515 series binary driver and the negativo17 package for Fedora…

… and we’re unable to spot the cause this issue. The short version: When trying to create a native Wayland swapchain it returns an error, but only when using the packaged version of the drivers. Is there something that stands out as a possible packaging bug?

Log is attached: nvidia-bug-report.log.gz (83.4 KB)

I believe this a 515.43.04 issue as it used to work on previous versions, see Vulkan wayland swapchain is broken on 515.43.04

Checked this against 515.48.07 and the issue still persists - despite the notes suggesting VK_EXT_debug_utils will explain the error, I didn’t see anything in the output. Is there something I should be checking specifically? Here’s our integration of the callback in FNA3D:

There is an ABI incompatibility between the 515 driver and previous versions of our egl-wayland library which might be the cause of this. Updating to the latest version, 1.1.10, should resolve the issue if that is the case.

Going forward this should never happen again as we’ve eliminated the driver <=> egl-wayland ABI which the Vulkan WSI depended on. However, doing so required one final breaking change, unfortunately.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.