No login console updating 470 to 510.85.2


I have the NVIDIA card GP106 [GeForce GTX 1060 3GB] driver: nvidia v: 510.85.02 in my laptop and use linux Devuan(Debian) testing for several years, using the Debian “nvidia-driver” package without any issue so far.

I use two monitor, an iiyama Prolite B2712HDS that is plugged to the Nvidia DVI port and an AOC Q2790PQU that is plugged in the nvidia hdmi port.

My system boot to console mode, then I start my desktop environment manually with “startx”.

After the nvidia driver update from 470 to 510.85.02, i can’t see the login console. I mean I see the detailed boot process after Grub screen, but at the moment the login prompt should happen, the screen goes suspend mode.

If I blindly enter my username/password ans “startx”, I can see my desktop. If I plug only one monitor, the console login screen is displayed normally. I tried to change cable connection (DVI/DP/HDMI) with no change.

I tried to record this on my phone (sorry for the poor quality)

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (587.8 KB)

Here it is

more or less, the same here with 520.56.06. detailed here Blank Screen at boot 520.61.05 ACPI BIOS Error RHEL 8 Alienware R13 RTX 3070 - #9 by sL1pKn07
nvidia-bug-report.log.gz (1.6 MB)

EDIT: i tried to run startx, but not works. only works if launch wayland session

updated to 525.53. same issue

nvidia-bug-report.log.gz (1.6 MB)