No module named 'omni'

In Omniverse Create, When tried to run python code in visual studio extension results in following issues

  • ModuleNotFoundError: No module named ‘omni’
  • Import “pxr” could not be resolved

Environment is on Ubuntu environment 20.04.6
omniverse install path /home/user/.local/share/ov/pkg/create-2022.3.3

Hi @sendil.kumar. Welcome to the forums! Please consider joining us on discord too: NVIDIA Omniverse.

Have a look at these two video sections to make sure your vscode project is configured correctly:

Keep in mind that Omniverse extension and libraries are typically not meant to be run in a standalone python interpreter. It’s meant to be run from within an Omniverse application.

Mati, Being new to this environment your information is help, by running with path & app references set to Create, along with Python Interpreter set to 3.10 version this issue is resolved, .

@sendil.kumar Glad that worked for you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.