Nsight unsupported GPU

Hi,

I am trying to run nv-nsight-cu-cli on an A100 machine. I am getting the following error

"sudo nv-nsight-cu-cli ./a.out
==PROF== Connected to process 145599
==PROF== Profiling “vecAdd” - 1:
==ERROR== Error 0: Failed to initialize PerfWorks/LOP
==ERROR== Failed to profile kernel “vecAdd” in process

==ERROR== Error 0: UnsupportedGpu
final result: 1.000000
==PROF== Disconnected from process 145599
==ERROR== An error occurred while trying to profile
==WARNING== No kernels were profiled
==WARNING== Profiling kernels launched by child processes requires the --target-processes all option
"

Machine details is as follows

OS: Ubuntu 20.04
Cuda: 11.1
Driver: 455.23.05

Thanks,
ASR

For anyone who run into the same issue in future:

I still dont know why these versions didnt work (it should have as the nsight version coming with cuda 11 should have supported a100).

I solved this by separately downloading the nsight (the specific version I used is https://developer.nvidia.com/gameworksdownload#?dn=nsight-compute-2020-2-0) and it worked.

Yes Nsight Compute from the CUDA Toolkit 11.1 which you tried earlier should have worked. In fact the Nsight Compute version in the CUDA Toolkit 11.1 is 2020.2.0 (which is same as the version you installed separately later).
Do you know the version of Nsight Compute which you tried first?
Also I suppose you used the same driver version 455.23.05 after installing Nsight Compute again?

The one I got with cuda 11.1 is

$ nv-nsight-cu-cli --version
NVIDIA ® Compute Command Line Profiler
Copyright © 2012-2019 NVIDIA Corporation
Version 2019.4.0 (Build 26818151)

//path cuda/11_1/bin

This could be due to some setup issue.
Nsight Compute version 2019.4.0 is an older version included in CUDA Toolkit version 10.1 Update 2. This version does not have support for the A100 GPU.
Also note that now a newer version of Nsight Compute 2020.3.0 is now available as part of the CUDA 11.2 Toolkit.

I installed it using the runfile (there was no prior cuda installation on the device).

Thanks for pointing to the 2020.3.0 and 11.2 toolkit.