Nv config apply "unrecoverable internal error"

Hi,

I have a new SN2010. Didn’t do much setup at first, apart from setting timezone and enabling NTP, which both worked fine. Then I upgraded from the installed Cumulus 5.1.0 to the latest 5.8.0.

Having done this, I can no longer even set the timezone. When I run “nv config apply” it fails:

cumulus@cumulus:mgmt:~$ nv set system timezone Europe/Paris
cumulus@cumulus:mgmt:~$ nv config apply
Failed to verify config [rev_id: changeset/cumulus/2024-02-29_16.56.53_0NWE]
  Unrecoverable internal error

If I look at my revisions I have one that is marked as having state “verify_error”:

cumulus@cumulus:mgmt:~$ nv config revision
Rev ID                                      State         Apply ID             Apply Date           Type  User     Reason         Message                 
------------------------------------------  ------------  -------------------  -------------------  ----  -------  -------------  ------------------------
applied                                     saved                                                                                                         
changeset/cumulus/2024-02-29_16.56.53_0NWE  verify_error                                                                                                  
empty                                       applied       rev_empty_apply_1    2021-07-21 20:50:08  CLI   cumulus  Config update  Config update by cumulus
startup                                     previous      rev_startup_apply_6  2021-07-21 18:55:32  None  root     Config update  Config update by root

I have tried doing: nv config apply empty and rebooting, but that has not helped.

Any suggestions most welcome! I wonder if getting rid of the “bad” config would help with this, but I can’t see how to do that.