NVidia GPU driver 440.XX - 450.XX bugs

Hello.

I want to report few very annoying and one critical bug (regarding critical bug I have no logs).
System information
NVidia card: Quadro K3100M. Laptop: Dell Precision M6800. OpenSUSE Linux Tumbleweed X86_64.

Bugs:

  1. NVidia settings doesn’t track normally power source (ACPId configured correctly). On laptop boot, NVidia drivers and NVidia settings see always “battery” power source, instead of AC. It’s disgusting, annoying and must be fixed finally. Combined with next bug, it’s really must fix.
  2. NVidia settings etc totally ignores performance profiles. Even selected “prefer maxim performance” or “prefer consistent performance” it drops it in some minutes and returns to default “dynamic” policy. With drivers 440.8X+ totally destroyed performance. Ordinary KDE desktop lags as hell and nvidia driver is stupid enough to still go down to low frequescies and slow going into rising gpu freqs. Also I want option that would be permanently saved, that run “maximum performance” just ALWAYS, so that even after reboot it returns to it. I don’t care of power usage (Optimus technology is epic nonsense and disabled in BIOS, so my laptop runs non-optimus mode always and Intel never in use. Also laptop has GPU as MXM replacable card with separate heatsink and active cooling system and temperature is never above 62 degrees which is just fine.
  3. NVidia drivers 450.XX series contain critical bug and must be declared unstable and reworked. Driver hangs after wake up on standby and randomly shows black screen with only mouse over it. Seems VSync and Sync VBlank somehow also affects it. I do not have logs, as system hangs on such error resulting with current work loss, so I don’t want to destoy my work with buggy drivers. Please fix. 440.100 doesn’t have this annoying bug that I currently use, but 2 bugs above exists on all drivers compatible with kernel 5.7.X series.

I attach x.org conf that helps me to fix KDE performance lags with nvidia drivers and bug report script output.

Ahh… Nvidia, you must be kidding. Why I can’t attach logs and configs? Why only image attach allowed?
https://mega.nz/file/apt13A7T#AaQmeUevu-A-SbMY6_CQkDLap12W0u_o4FnK1D_BBNY
https://mega.nz/file/K0ljCArY#ldhTIRihApftFNHHMqIbHSjkBTSupUW6-VF8q982jvU

1 Like

On my desktop with a GTX-2080 Super, and I also now get a black screen on pretty much any resume from sleep wake-up after updating to 450. Arch Linux, 5.7.9-arch1-1, KDE 5.1.9.3, QT 5.15.0, KDE Frameworks 5.72.0. nvidia-450.57.

I have made series of tests.

I hope someone of NVidia team also will look at this topic and bug report.
Came out that all performance politics etc ignored (definitely a bug) if checkboxes “Sync VBlank” and “Allow flipping” are disabled. (More obvious dependent on sync VBlank).

Also, NVidia, please make driver update ACPI state to detect if power source is AC or battery. I am tired of need to detach power cord and attach back for NVidia settings to see that it’s running on AC, not on battery.

And I have latest KDE as OpenSUSE Tumbleweed release. Driver series 450.XX fail hard. Seems like OpenGL issues. Common issue, that after wake up from sleep mode I see black screen and mouse over it (meaning 2 graphics work after wake up, but 3D, namely OpenGL - fail. I mention once again, that It’s not Optimus laptop, Intel card disabled on BIOS level and NVidia is the only active card, in my case MXM card, the replacable one).

I am also affected by the resume from sleep mode blank screen with cursor. Reverted back to 440.100 for now. Latest Arch and KDE plasma.

1 Like

Bug report on nvidia 450.57 on kernel 5.8 https://mega.nz/file/u4kj0JCC#anI44qOxMNNIK2fga_ZQpt-MrYIA8xbohg83KazZwC0

And 100% I was right - driver has buggy OpenGL https://mega.nz/file/6k9DFbqB#fMhL0jhFOmzYkbTqcsy-ovflBjBIJGIqsySlYNBT2nI

Hello,

On my HP Zbook 15 G6, I also encountered problems with Ubuntu 20/ Mint 20.
I first published a post about it here before being forwarded to this forum.

First of all, the 450 simply doesn’t work for me (either the screen completely freezes on logon, on Ubuntu 20, or it simply wont start on Mint 20 : blinking white cursor on black screen). nvidia-smi doesn’t work for me on 450, while it works on 440. I can add that there is a secure boot and I had to enroll keys to add EFI entries (successfully).

Nvidia Quadro T1000 is my GPU.

Even if it works on 440, the refresh rate often seems poor compared to Windows on the same machine, on YouTube, for example.

Kernel used : 5.4.0-42.

In every case, the acpi error is returned by Ubuntu/Mint on startup.

This last point seems to be lasting for several months so please Nvidia correct this point. it’d be great.

Thanks.

1 Like