Nvidia linux driver 367.57 and up do not install on kernel 4.9.0 rc2 and higher

I’m on OpenSuse Factory/Tumbleweed this is a rolling distro with bleeding edge code and software repos and I like to use the latest testing kernels.
Only problem is Nvidia linux driver can not compile on kernel 4.9.0 rc2 and higher.

I have tried with
367.57 can not build kernel module (nouveau driver also gives no video output)
370.28 can not build kernel module (nouveau driver also gives no video output)
375.10 can not build kernel module (nouveau driver also gives no video output)

Even my internal Intel Graphics 2000 is working on this kernel so why a new device as Geforce 750 TI does not work.
Is it possible for the developers to make the graphics driver integrate simpler into kernel, this is unacceptable.
Nvidia video cards are not cheap so it is just a real bummer that it does not work.
Another nuisance is the constant reinstalling of the driver if for example mesa gets an update, please find a way to go around this problem.
I attached an error log from the installer, can someone take a look at it and resolve the issue.

Thanks in advance please
nvidia-installer.log (56.8 KB)

Your problems with this painful driver release 367.57 are really small scale…with me it destroyed the whole linux installation to an unusable form. It happened to me 3 times!

It seems that this 367.57 is really bad code for any Linux system!!
No-Love-Lost-Between-Linus-Torvalds-and-NVIDIA.jpg

No-Love-Lost-Between-Linus-Torvalds-and-NVIDIA.jpg

I’m sad to hear that which linux distro were you using when this happened ?
In my case the driver does work up to kernel 4.9.0-rc1 on any higher kernel it won’t compile.
Is your problem solved and if so how ?
I now understand you are not a developer from Nvidia and I really need one of them or all of them to fix this issues.
Such a big company must be capable to do this I guess.

Hi my favor of Linux is X86_64 with a 4.1.18 kernel using 367.57. It was previously upgraded from a 357.30 driver. I will reply back because I have another system using a 4.6 kernel. I do not recall the Nvidia driver version but I believe it to be the same. This chip uses the Maxwell family, gm107,…, there are related files for mesa, drm, and X. I use a different version of Linux but it must be closely related. My configuration has two cards, a 960 GTX and 730 GTX; the 960 is Maxwell, and the 730 is Kepler (gk208) and it is working.

The Getting Started Guide does show the compatibility matrix with glibc and others. I had to modify some of the make files so it not error out on compiler checks… that is another story.

There is a beta driver for 375.10 for Linux

Version Release Date
Linux x64 (AMD64/EM64T) Display Driver BETA 375.10 October 20, 2016

See below. I have not tested this yet but I will next week after the 20th.

http://www.nvidia.com/download/driverResults.aspx/109244/en-us

Thanks for your asnwer but how is this any usefull to me ?
You’re telling me about a beta driver which you haven’t tested yourself yet but as you had read my post you could have seen I already tried that one and it does fail the same way.

Is there nobody from the Nvidia developers able to take a look to my included installer.log in first post and tell me if this can be fixed by user or have to wait for new driver version or tell me something, anything.

I bought this card because of the good name of Nvidia but I rather wish I did not buy this expensive piece of crap even my buildin Intel 2000HD grapics works on all kernels with no problems.

Can one send his card back to nvidia for a refund ?

Just a friendly advice, Why not use the stable 4.8.8 till 4.9 is released?
There is usually an update for NVIDIA or patch for major kernel releases.
The term ‘rc’ in the Linux kernel is very optimistic in my experience. They are no where near ‘rc’ quality a lot of the time.
An out-of-tree module that compiles on rc5 can easily break on rc6.
I think once 4.9 reaches the final two RCs, a patch will appear.

4.9 will be released in December so you will not have to wait forever.

Thanks that is a helpfull reply.

Q:Why not use the stable 4.8.8 till 4.9 is released?

A:I’m on OpenSuse Factory/Tumbleweed this is a rolling distro with bleeding edge code and software repos and I like to use the latest testing kernels.

The fact remains that I still can not understand why Nvidia is not capable in making a driver that is working on any kernel version like for example intel hd2000 graphics and why they do react so poorly on support requests?

Thanks HussamT for this workaround, but I let this question stand as this is fooling oneselfes I already knew it is working with 4.8.8

  • In my case the driver does work up to kernel 4.9.0-rc1 on any higher kernel it won't compile.
  • Another nuisance is the constant reinstalling of the driver if for example mesa gets an update, please find a way to go around this problem.
  • I guess I’m going to give away this videocard and get my self a new processor with integrated intel HD graphics it saves me from the hassle of rebuilding driver with every change of kernel or mesa and the kinds of software, this Nvidia software is if I may say it like this not very stable or full grown.

    Just as stated above, why not use a stable kernel? According to OpenSuse release notes, it states there are problems when using the latest and greatest releases. “rc” stands for Release Candidate and not the final stable release.

    In the release notes for OpenSuse https://doc.opensuse.org/release-notes/x86_64/openSUSE/Leap/42.2/ states in section 1.5 with links to bugs. This is nothing new and will continue to show up on new kernel releases and as new hardware is introduced into the marketplace.

    The Intel graphics card has is own issues but much simpler than Nvidia. Yes, there are licensing issues and proprietary issues but it is not an end to all means. Furthermore, following the release notes and bug reports, there are many issues with open software and applications working well together. It has matured over the years. If you have been an application developer on Windows for example, they needed all the developers to use the same APIs so applications can interoperate more easier without specialize calls and routines. Apple learned this in the early years… This exist today in Windows, Linux, and other Operating Systems. On Linux, QtWebEngine uses multithreading, Chromium renders in one thread, and Qt composites in another (different) thread, so they use different methods and algorithms which can cause deadlocking. This last part was stated by a very respectable person if you follow the bug threads.

    I use a stable kernel for my primary system on Linux. I also test Linux releases specifically with Nvidia proprietary drivers. As they say in software, there is a paradox, there is leading and bleeding in the edge of technology or the bleeding and leading edge of technology…

    If you thinking about donating it, please contact the Nouveau mailing list at Nouveau@lists.freedesktop.org
    https://lists.freedesktop.org/mailman/listinfo/nouveau

    They are looking for Nvidia cards so that they can test with. What you are experiencing is common with that Linux distribution on recompiling and etc. What is wrong with the 4.8.8 kernel if most things are working? I am getting use to not using “all” anymore…

    I disable my Intel Graphics HD card…

    Are you from Nvidia or just another user like me ?

    That’s nice for you that you work with stable kernel I work with testing as stated before.

    In my opinion it does not have to matter which kernel I use basic functionality of videocard should work, I would understand if some specilized options wouldn’t work yet as they are not optimized for the newer kernel yet.
    But what I am talking about is that it is totally not working I can not use a Graphical Desktop Manager only textmode.
    This is unacceptable for such an expensive videocard even my cheapass Intel hd graphics 2000 from 2010 does not have this problem it can and will start a Graphical Desktop Manager anytime.

    I am going to give the videocard to my neighbour his son he likes to play games on his windows PC and he has already the same card so now he can make it work with SLI or something he told me.

    Nevermore Nvidia for me it was a bad experience and no real support only other users answers on questions, that alone is for me enough to understand they are not in to the linux support I hope they are better in Windows support.

    First, I do not work for Nvidia. That 750 TI is a great card and fast! Windows and Linux are entirely different from a development and support model as you know. I use the Nvidia cards for programming C/C++ CUDA/OpenACC. I run into the same problem all the time when a new kernel is released as in “rc” or “0.0”. The drivers have dependencies on other libraries to work for certain functionalities. I follow the development tree from several companies and contribute by testing, coding, and reporting.

    I have specific new hardware just for testing functionality and compatibility. Nvidia development uses many platforms if you look at the installation for the CUDA Toolkits and other toolkits in their offerings, you will see that they are strong supporters of Linux. They support Windows, Mac OSX 64bit, PowerPC, Linux (they name these specifically: Fedora, OpenSUSE, RHEL, CentOS, SLES, and Ubuntu), and provide drivers. My Linux distribution is not even listed but it is closely related as a fork of Fedora. I am up and running on a stable Linux kernel. I have these challenges during testing and they are related with mesa-dri. If you check out the forums of the other Linux providers, they run into the same problems and they all sometimes come up with different workarounds. Some disable 3D rendering, some have flags to work with kwin (KDE), and some wait it out because of the effort/time in providing a temporary solution could be spent solving other bugs.

    The new driver 375.20 fixed all my issues, thanks Nvidia