NVIDIADeepStreamSDK IoT Image Is Broken

When I run this image ( https://azuremarketplace.microsoft.com/en-us/marketplace/apps/nvidia.deepstream-iot?tab=Overview ) in a container on a jetson nano the container fails to start with error

“Container fails to run (gst-plugin-scanner:6): GStreamer-WARNING **: 18:47:09.647: Failed to load plugin ‘/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_infer.so’: libnvparsers.so.5: cannot open shared object file: No such file or directory”

I am on the latest Jetson Nano Image + Installed the DeepStream SDK ( https://developer.nvidia.com/deepstream-402-jetson-deb )

Hi,

It looks like there is no TensorRT package on your environment.
Have you installed the “Jetson SDK Components” from sdkmanager?

Thanks.

Yea I have tensor RT installed and the Jetson SDK components.

Hi,

libnvparsers.so.5: cannot open shared object file: No such file or directory

JetPack4.3+Deepstream 4.0.2 already upgrade TensorRT package into version v6.0.

It looks like your container requires TensorRT v5.0.
Could you give JetPack4.2.3 + Deepstream 4.0.1 a try?

Thanks.

Hi

Thanks for the reply. Thats defiantly getting me down a path somewhere, however, I am using Microsoft/ Nvidia’s docker image located here https://azuremarketplace.microsoft.com/en-us/marketplace/apps/nvidia.deepstream-iot?tab=Overview

I don’t think I have any control over setting JetPack4.2.3 + Deepstream 4.0.1… I do follow your logic though…

Hey there,

I have been having the same issue for the last couple of days. I tried using both the latest Jetson Nano Developer Kit SD Card Image (w/ JP 4.3 & Release Date 2019/12/17) and using the SDK Manager to install JetPack 4.3 + Deepstream. Additionally, I confirmed that I using the ARM64 Nvidia Deepstream SDK Azure marketplace module. None of these steps resolved the error.

I can confirm from my testing that using Jetson Nano Developer Kit SD Card Image w/ JP 4.2.3 & Release Date 2019/11/19 resolves this error.

I am not sure what the difference is between these two versions. This issue will most likely need to be resolved by Nvidia since the latest SD Card Image does not work with the latest ARM64 Nvidia Deepstream SDK Azure marketplace module.

For now, I recommend using the older SD Card Image until this issue is resolved by Nvidia. You can download it at the Jetson Download Center.
https://developer.nvidia.com/embedded/downloads

Good luck.

Hi, jwf5426

Thanks for the feedback.

The main difference is we upgrade TensorRT package into 6.0 in the JetPack4.3.
This make the docker image cannot find the corresponding v5.0 library and leads to this error.

libnvparsers.so.5: cannot open shared object file: No such file or directory

The container doesn’t support our latest software yet.
I will pass this issue to our internal team and request for an update.

Thanks.

Hi, mitchross09

Sorry for the non-clear statement.

On Jetson, container will try to access the library/driver/software on the Jetson device.
In this container, it required your Nano is setup with JetPack4.2.3 JetPack4.2.2.

So, would you mind to reset your device with JetPack4.2.3 JetPack4.2.2 and give it a try.
This is an option from sdkmanger.

Thanks and please let us know the result.

Jetpack 4.2.3? Does it pertain to sdcard image or sdkmanager? Both? Any? Or neither of the two?

For sdkmanager downloads I can see:

JetPack 4.3
Jetson TX2 Family, Jetson AGX Xavier, Jetson Nano, Jetson TX1 [L4T 32.3.1]
JetPack 4.2.2
Jetson TX2 Family, Jetson AGX Xavier, Jetson Nano, Jetson TX1 [L4T 32.2.1]
JetPack 4.2.1
Jetson TX2 Family, Jetson AGX Xavier, Jetson Nano, Jetson TX1 [L4T 32.2]
JetPack 4.2
Jetson TX2 Family, Jetson AGX Xavier, Jetson Nano, Jetson TX1 [L4T 32.1]

[from https://developer.nvidia.com/embedded/jetpack-archive]

sd image download:
https://developer.nvidia.com/jetson-nano-sd-card-image-r3223

Hi,

Sorry that JetPack4.2.3 is not available now.
Please use JetPack4.2.2 instead.

By the way, there is also an deepstream iot container in our NGC website.
We have confirmed that it can work with JetPack4.3.
https://ngc.nvidia.com/catalog/containers/nvidia:deepstream-l4t

Thanks.

Thank you for the update.

To clarify, I got the disk image with JP 4.2.3. from the Jetson Download Center. The selection to download this disk image looks like the image below.
https://user-images.githubusercontent.com/19712696/71769828-c5e0dc00-2ef3-11ea-817f-b286b19745f7.png

Below is a hyperlink to download that image.
https://developer.nvidia.com/jetson-nano-sd-card-image-r3223

I am not sure why it is not available in the SDK Manager.

Hi,

Our internal team is updating the container on Azure into Deepstream 4.0.2, which is compatible to JetPack4.3.
We will update more information once it is done.

JP4.2.3 is removed few weeks ago of sdkmanager
Thanks.

How can I find out when this container is updated?

Any update?

meanwhile, you may use the default DeepStream and use the corresponding text config files to link it with Azure
quote:

Using Azure MQTT protocol adaptor with message broker
=======================================================================
Refer to the README files available under sources/libs/azure_protocol_adaptor
for detailed documentation on prerequisites and usages of azure MQTT protocol
adaptor with the message broker plugin for sending messages to cloud.

Refer to the source code and README of deepstream-test4 available under
sources/apps/sample_apps/deepstream-test4/ to send messages to the cloud.

end-of-the-quote
readme.txt (3.37 KB)

The Deepstream SDK 4.0.2 is now available on Azure marketplace.

What is the new image path? For example currently im using

"modules": {
          "NVIDIADeepStreamSDK": {
            "version": "1.0",
            "type": "docker",
            "status": "running",
            "restartPolicy": "always",
            "settings": {
              "image": "marketplace.azurecr.io/nvidia/deepstream-iot-l4t@sha256:d452eed1bed8970bed4e1008d182a0eec7bc83dcda1306c50513b79f2d989942",
              "createOptions": "{\"Entrypoint\":[\"/usr/bin/deepstream-test5-app\",\"-c\",\"/opt/nvidia/deepstream/deepstream-4.0/samples/configs/deepstream-app/source4_usb_rtsp_dec_infer_resnet_int8.txt\",\"-p\",\"1\",\"-m\",\"1\"],\"HostConfig\":{\"runtime\":\"nvidia\",\"Binds\":[\"/opt/nvidia/deepstream/deepstream-4.0/samples:/opt/nvidia/deepstream/deepstream-4.0/samples\",\"/run/systemd:/run/systemd\",\"/var/run/docker.sock:/var/run/docker.sock\"]},\"WorkingDir\":\"/root/deepstream_sdk_v4.0.1_jetson/sources/apps/sample_apps/deepstream-test5/configs/\"}"
            }

the deepstream SDK 4.0.2 can be found herehere