Omniverse launcher says i need 471.41 driver?

I have an Nvidia rtx 2060 running 496.76
I tried to download the 471 version but it says its not compatible with my system how can i get it to work

Hi @user64159 - and welcome to the Omniverse community!

I apologize for the confusion: the message you are seeing in the footer of the Omniverse launcher, “REQUIRED DRIVER FOR OMNIVERSE COMPATIBILITY”, is a general announcement for all users, regardless of the driver installed. It links to this page, which provides the minimum recommended drivers for Omniverse RTX.

For reference, the general technical requirements for Omniverse are here.

As you can see from above requirements, your GPU will likely struggle with Omniverse RTX - although we have seen some users have success with Create and the 2060.

Cheers,
Edmar

P.S. We are constantly adding new tutorials and aggregate them all in the “learn” tab on the launcher (also see: NVIDIA Omniverse Tutorials | NVIDIA Developer).

he / him | LinkedIn | Discord ID: Prof E#2041
Omniverse: “A New Era of Collaboration and Simulation” (video)
Omniverse Create’s latest features show & tell: Twitch livestream.
As seen in VentureBeat | Physics Showcase

Omniverse Resources:
Open Beta | Documentation | Tech Requirements | Videos | Roadmap | Twitter | Discord | Twitch

PLEASE NOTE: If you are reporting a bug/issue, please provide OS, GPU, GPU Driver, the version of the app, and full log file (if applicable). For crashes, please zip and provide a link to your logs → C:\Users\ [YOUR NAME] \ .nvidia-omniverse\logs