Pass audio without encoding to AAC mpegts

I am now encoding the audio to AAC, is there a way to copy the incoming audio track to output? like in ffmpeg -acodec copy?
input audio is mpeg-1 layer 2


gst-launch-1.0 souphttpsrc location=  ! progressreport ! decodebin name=demux demux. ! audioconvert ! voaacenc bitrate=64000 ! queue ! mux1. demux. ! deinterlace ! queue ! nvvidconv interpolation-method=5 ! "video/x-raw(memory:NVMM),width=1280,height=720,format=I420"! nvv4l2h264enc maxperf-enable=1 control-rate=0 peak-bitrate=4000000 bitrate=3000000 preset-level=1 profile=High insert-sps-pps=1 iframeinterval=250 ! h264parse ! mux1. mpegtsmux name=mux1 ! tcpserversink host= port=1001

This would need other users to share experience. We have tried to bypass aac stream in transcoding and also fails. Need to re-encode like this command:
Convert .ts file to .mp4 - #7 by DaneLLL

Wouls be great if other users knows how to bypass the stream and can provide tips.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.