Physics seems too slow compared to real world

I lined up some dominos, and I am able to get them fall, but all the dominos videos I have watched dominos fall really fast. Like 5 per second guess, vs in Omniverse it is about one domino every second or two, and that is with only 10 in the scene.

I saw a setting like time frames per second, but I think that just comes from the frames per second from the timeline.

I tried changing gravity, and that didn’t seem to change the time.

Thanks if there is a way to make things fall faster.

Try to run nvidia-settings; under X screen 0 → click on OpenGL Settings.
Maybe you have enabled Sync to VBlank?
Disable it and save these settings using the last “nvidia-settings Configuration”

You lost me at nvidia-settings.

How do I get to that?

Whatever is enabled is the default options, because I don’t know how to do any of what you are talking about.

The only thing I found under Nvidia Settings (I think I found it, is OpenGL Rendered Settings had Automatic, I changed to my GPU, not sure if that will make any difference.

I don’t see anything called VBlank. I do see something called Vertical Sync, which had Application Settings.

I am in the right place?

Hi,
can you please share your asset? In general gravity is the thing to setup, but note that by default gravity is derived from the units. This is the most crucial thing, to have matching units (metersPerUnit) with your scene objects.
You should get similar “real” world behaviour if the units match.

One thing I did do to speed it up some, is I placed the dominos closer together, so there was less time spent “falling” for each piece.

It still seems a little slower than it should.

DominosFlattened.usd (785.0 KB)

Could you please post screenshot(s) of the settings I need to match up?

Let me know if you need anything else.

Thank you for your help.

Corby

So here you really need to pay attention to units, your units are in cm (in layers window select the layer, in properties panel you will see metersPerUnit = 0.01).
Your dominos are 1m size, you can easily check that by creating a shape cube, its 100 size which is 100cm = 1 m in your scene. If you do that you will see that each domino is 1m height. So there you get completely different behaviour then with real dominos that are say 4 cm height.

I did a small test by scaling down the dominos and stacking them, I think this behaves as you would expect? (note the large cube behind, thats 1m cube)

I guess I wasn’t thinking about “size”. I can see how a larger 3 foot domino would take longer.

I will adjust my dominos, and I also realized I need dots on both sides.

Thank you.