Preferred method for getting openalpr working on Jetson Nano

I’ve had limited success over the past few days trying to get openalpr up and running on my Nano so I’m wondering if others have had success and if so, how you did it.

So far I’ve tried:

  1. Flashing JetPack 4.2 and updating
  2. Installing RasPi v2 camera
  3. Cloning and modifying to support /dev/video
  4. Run It complains about cv2 not being installed. I tried installing python-opencv via apt which allowed the script to run but it just hung and didn’t produce any output
  5. I then tried to manually build opencv 4.0.0 using the Nano install script. I eventually got the build to work but then compiling openalpr to use it failed miserably due to API mismatches.

I’m currently trying to build/install opencv 3.4 manually to see if that helps but I’d love to hear if someone else has a documented procedure that works so I can run openalpr with GPU support on the Nano.

Thanks in advance!


Sorry that we are not familiar with the script

But suppose you can install openalpr library and run it directly:

alpr -c us ea7the.jpg

By the way, we have cooperated with OpenALPR team to implement a sample for DeepStream API.
The patch optimize the camera pipeline and give you a much better performance.

The deepstream API will be available for Nano on Q2 2019. And the patch will be released after OpenALPR team integrated.


Any update/link to that you might be able to give?