Problem in building OpenCV 2.4.8 library with Cuda 5.5 on Window 7(64-bit) and Visual Studio 2010.

I am trying to build OpenCV library with Cuda support using Cmake and VS 2010 . But everytime the build fails with basically two kind of errors and they are—

Error 1 error : nvcc supports ‘–relocatable-device-code=true (-rdc=true)’, ‘–device-c (-dc)’, and ‘–device-link (-dlink)’ only when targeting sm_20 or higher C:\build\modules\core\nvcc opencv_core

Error 2 error LNK1104: cannot open file ‘…\lib\Debug\opencv_core248d.lib’

I have verified that Cuda is installed properly by running deviceQuery application through Command Prompt and got Result=Pass . So i am sure that Cuda got installed properly . I am not sure of configuration of Visual Studio With Cuda though. But i guess if Cuda is installed properly then Opencv library should get build successfully.And yes Opencv library is getting built successfully without Cuda support so I am damn sure that it is something related to Cuda or Cuda configuration.

Please help me . I have been trying to solve it from past 1 week but not got it solved. Tried with many suggestions by peoples but still the problem persists.

Thank you.