Problems getting context

I have a Lenovo T61 laptop with Nvidia quatro 140M. OpenCL usually works after booting the system (not always), but stops working after some time. The programs return error code about not having enough host memory when creating the context. I’ve tried with many of the demos that come with the SDK. I’m using the 190.29 drivers, and also tried with the lastest beta 195.30 but that’s even worse :)

Any ideas are appreciated.

I have the same problem with my own code. After executing multiple times I got the same error.
Haven’t tried driver 195.30 yet, but I will do.
Good to know I’m not the only one with this problem, and that it is also happening with the examples.
I thought it is a problem of my code. But it seems to be a memory leak somewhere in the nvidia implementation.

I use 195.17 on Ubuntu 9.10 , 9600 GT (its a desktop) - works fine.

What OS are you using?

The drivers are non-stable releases as you know, as an idea, are you releasing all of your memory at the end of the applications (both device and host)?


Your answer is most likely in this thread (

The newer drivers require that you have a platform when creating a context. In the CUDA 3.0 Beta SDK, few (if any more than one) have a sample of this code. I can’t remember which example uses it but if you change it round, it will work.