Problems settings compiler-options /Xcompiler option does not work correct

Hello,

I’m using the compiler-bindir in the nvcc.profile file in order to simplify our custom build process.

My problem is, that I also want to use the compiler-options in the nvcc.profile, but this doesn’t work (at least as far I found out). So when I use the /Xcompiler switch to set the options for the compiler this doesn’t work, I also have to specifiy the -ccbin.

When using the command line below I get followingt message:

Command line error D2021 : invalid numeric argument ‘/Wp64’

My custom build command looks as following:

[font=“Courier”]nvcc.exe -c -Xcompiler /EHsc,/W3,/nologo,/Wp64,/Od,/Zi,/RTC1,/MTd -D_DEBUG -DWIN32 -D_CONSOLE -D_MBCS “myfile.cu”
[/font]

the nvcc.profile looks as following

[font=“Courier”]TOP = $(HERE)/…

PATH += (TOP)/extools/bin;(TOP)/open64/bin;(TOP)/bin;(TOP)/lib;$(TOP)/common/lib

INCLUDES += “-I$(TOP)/include” “-I$(TOP)/include/cudart” “-I$(TOP)/common/inc” “-I$(TOP)/…/CPP/include” -

LIBRARIES =+ (_SPACE_) "/LIBPATH:(TOP)/lib" “/LIBPATH:$(TOP)/common/lib” cudart.lib cuda.lib cutil32.lib

CUDAFE_FLAGS +=
OPENCC_FLAGS +=

compiler-bindir = Z:\IPIPE\tools.p\CPP\bin\

PTXAS_FLAGS +=[/font]

Do you have a solution how I can specify the compiler-options also in the nvcc profile?

Thanks in advance
Martin

I would expect some more presence of the nvidia team here to answer the questions. :thumbsdown: