Problems with CUDA on both Ubuntu and Windows

Hi everyone, I already posted in another forum but the support suggested that I post here.
I’m on a Lenovo Y50-70, GeForce GTX 860M, Driver Version 384.94. I’m having the following problems:

-I installed CUDA 8.0 on Windows, tried building on Visual Studio 2015 but everything that I do gives me

error msb3721 exited with code 1/2

(no luck setting verbose mode, no additional info)

-Tried with CLion, including everything in CMakeLists, but

find_package(CUDA REQUIRED)

fails with

Could NOT find CUDA (missing: CUDA_CUDART_LIBRARY) (found version "8.0")

(I checked in the directory, the PATH is correctly set and the cudart library is there in the lib folder.

-I tried installing CUDA on ubuntu, but the Graphic driver installation fails with this log https://pastebin.com/b6FLYvLB.

I sincerely don’t know what else to try. Any ideas? Thanks, and sorry if it’s posted wrong or in the wrong forum

You should be able to build the CUDA sample projects. Are you attempting to build one of these? If the msb3721 is reporting that error associated with CUDA/nvcc, I guarantee there is a way to see the actual nvcc error report, and that should be instructive.

If you are attempting to build one of the CUDA sample projects, and get this error, then turn on verbose mode and paste the actual compile output into this thread.

I swa

Thanks for the reply!
I swear verbose mode doesn’t give me any other output.

I’m actually trying actively with CLion now, I feel like I’m close. Still missing cudart library, I tried editing the FindCUDA.cmake:

-commenting out that library works (of course any function on thrust don’t work because of the missing component)
-setting another path in find_library doesn’t work, I tried moving cudart.lib to desktop etc but no luck.
Any ideas about that?

I don’t know how to set up CLion. If it were me, I would try to get VS working as that is the defined/supported environment for CUDA. CMake introduces an additional layer of complexity, in my view. But to each their own. Good luck. I can’t help you with VS if you don’t want to respond to the things I ask for.

again, thank you very much for answering me and thank you for your help.
Yes I tried to build the CUDA samples in VS, yes I tried the two settings for verbose mode and no, no other information was printed. If you don’t believe me I’ll post a screenshot, but I sincerely hope you do.

I believe you. In spite of that, I’d like to see the output. I’m not saying for sure I can help you, but if there’s any chance of success, I’d suggest the following:

After installing CUDA, without making any other changes or modifications, try to compile the deviceQuery sample project. Then please copy and paste the text output into this thread.

Please don’t post a screenshot. The console output from VS is in a text window, and you can easily copy and paste the complete text generated there from a compile command. I want to see everything that VS spews into that window during compilation.

This avoids me having to play 20 questions with you, to tease out additional details besides this:

error msb3721 exited with code 1/2

I believe the suggestion around verbose mode is appropriate in this scenario, and I have given that advice to good effect on a number of occasions with respect to VS and msb3721 error, here is one example:

https://devtalk.nvidia.com/default/topic/989584/how-to-fix-error-msb3721/

But I certainly don’t know what exactly is happening in your case. To that end, I am asking for more info and make a few typical suggestions that have been useful in the past.

Again, if you don’t want to do it, don’t. I don’t care. It’s not about a matter of trust, or anything like that. I know what I’m doing, and this is how I work. If you want to work that way, I’ll try to help.

if you don’t want to, that’s your call. Maybe someone else will have some ideas and be able to dive in. Perhaps you will figure out how to get CLion working for you.

okay thanks will do!

seems like somebody has figured out CUDA, CLion, and CMake:

https://stackoverflow.com/questions/45462411/code-parsing-not-working-with-cuda-clion-and-cmake