Program won't start

I’ve installed the debugger on my Gentoo system. When I start it, I get a dialog box saying

"Some modules failed to load successfully.

The application will now exit."

Not a very helpful error message. What’s missing? What needs to be installed to run the program?

Hi Dragor42,

Please try these:

  • run with LD_LIBRARY_PATH with your Linux Graphics Debugger’s installment path
  • run with root


I have tried running as root and Setting the LD_LIBRARY_PATH before running the program. I have used ldd to confirm that all of the libraries for the nvidia-gfx-debugger.bin program are found.

I should be clear, the program starts, but it only displays a dialog box saying that it cannot load modules. What modules is it trying to load?


Hard to say why, maybe you can try to do some strace or debug? also maybe you can try on Ubuntu, I am guessing something mismatch on your system with linux graphics debug.


I’ve tried strace, it doesn’t show any libraries that are trying to load and failing. This is something internal to the program. What do you mean by debug? I’ll see if I can setup a Ubuntu system for testing.

Same thing here. Could be chill if Nvidia put exact requirements for the program into readme, coded some sane error logging or actually published sources for the tools its releasing for open-source systems instead of pretending that everyone in linux world runs ubuntu.

Actually on further investigation ./nvidia-gfx-debugger.bin gives

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Hi Mytishy359,

What’s your Linux distro?



I found a solution.

The preserved debug info allowed me to see where the problem was

This plugin is located here ./Plugins/TGDPlugin/
It depends on a huge amount of libraries but this caught my attention

$ ldd 
... => /lib64/ (0x00007f788ddcf000) => not found

Somehow I had managed to mess up GL libraries and now wasn’t present at all.
I use Fedora. This library is part of the mesa-libGLU package and “dnf reinstall libGLU” saved the day.

Still it would be nice to see better error reporting in future versions.

for me this was caused by lack of from pulseaudio. why is it not bundled and why would graphics utility need this awful audio lib is beyond me.