Quantum ESPRESSO GPU compilation


I am trying to compile Quantum ESPRESSO with GPU support, after running “./configure --with-cuda=“usr/lib/cuda” --with-cuda-runtime=11.7 --with-cuda-cc=7.5 --enable-openmp --with-scalapack=‘yes’ --with-cuda-mpi=yes --libdir=”/opt/nvidia/hpc_sdk/Linux_x86_64/22.7/math_libs/lib64"" i tried make all after which I am getting a frequent warning like this “nvfortran-Warning-CUDA_HOME has been deprecated. Please, use NVHPC_CUDA_HOME instead.” it continues but after a while the compiler automatically stops
any help regarding this will be useful


Hi Ron,

I don’t build QE myself so will need to reach out to some other folks for help. Though first, I’ll need a bit more info.

My assumption is that the warning shouldn’t matter. The NVHPC ships an integrated version of the CUDA SDK and we used to use the CUDA_HOME environment variable as the way to have the NVHPC compilers use a different CUDA SDK install. Though we found some issues with this setup, so moved to using NVHPC_CUDA_SDK for this instead. CUDA_HOME is strictly for use with the CUDA SDK. The warning is just letting you know of the change in behavior.

Can you give more details on what you mean by “after a while the compiler automatically stops”? Is this when you’re running configure, or is this during the make build? If configure, are there any errors? Does the log file give details on the errors?


hey mat,

Firstly thank you very much for your reply, I tried asking some more people and I got to know that I have to install “M4” basically I had trouble in make build, I was not able to compile FoX but after installing “M4”, everything went smoothly!.

thank you for your time!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.