Raspberry Pi HQ Camera Compatibility

Built and flashed according to instruction.

Target fails to start HDMI display, just keeps trying to start display, and showing the log printouts.

Any ideas?

@DavidSoto-RidgeRun thank you so much for your work !
Could it be possible to have an image of JetPack 4.4 for the Xavier NX with the IMX477 driver already installed on it (for example in the port 0 of the board) ?

1 Like
  1. Are you using Jetson Nano or Jetson NX? At this point we have tested only in Jetson NX, we will be testing in Jetson NX this and the next week.

  2. Are you using the devkit or a custom carrier board?

  3. What Jetpack version are you using?

Sure, we will add this to our backlog to speed up the testing process.

Yippee, I got the Raspberry PI HQ Cameras running today!

You have done a great job, thanks!!!

But the image is flipped

Tried setting the orientation (0x101) register of the sensor, but then the color format changed from" rggb" to “bggr”.

Updated the device tree with the format, but then the ISP calibration seems to be mixed up, image get blurry.

Rally waiting for the binning mode

Hi all,

You may encounter some issues where the display blinks, network is not working properly or you don’t see the graphics. It is because you need to update the kernel modules too when the kernel is updated the very first time. We added a new section in the installation wiki to include those steps: https://developer.ridgerun.com/wiki/index.php?title=Raspberry_Pi_HQ_camera_IMX477_Linux_driver_for_Jetson#Copy_the_kernel_modules

Great initiative guys!

Few questions :

  • Does the resolutions and frame rates mentioned are supported on the jetson nano devkit ?

—1920x1080 @ 60fps
—4032x3040 @ 30fps

  • as it seems that the raspberry pi hq doesn’t have any ISP, do you guys use the jetson nano isp ? If not, do there is some CPU/GPU overhead (in percent) ?

  • Is this driver compatible with the Arducam version of the raspberry pi hq ?

  • will leopard imaging provide a IMX477 MIPI camera at some point ? (Without removing the transistor)

Thanks in advance and continue your great work!

VIncent

HI,

The “Compile kernel, device tree and modules” has the argument “-j4”.
Is that based on your PC configuration or mandatory?

Hi Vincent,

Glad to hear that the driver is useful for you!

  1. Next week we will be testing in Jetson Nano, this early-version was tested on NX only. However, we expect to have the driver working in Jetson Nano without a lot of work.

  2. The camera does not have a built-in ISP, it gives bayer. We are using the Jetson ISP for debayering and Leopard Imaging is providing the ISP calibration file. They are working on a new version of the calibration file as well to improve the image with the custom lenses for the HQ camera.

  3. We have not tested the Arducam, we don’t have one camera yet but should be easy to support starting from the driver that we created. We would be happy to extend the driver to make it work with that camera. If you are interested in our V4L2 driver services please contact us.

  4. RidgeRun is a software only company, we don’t do hardware so we don’t know if LI is planning a new camera. You will need to contact Leopard Imaging directly for more hardware information.

-David

2 Likes

This argument is to use more core to compile the kernel, you can remove it or just adjust according to your computer.

@DavidSoto-RidgeRun

Are there any plans for a DKMS package like with the Coral modules?

Hi, Eagerly waiting on driver support for Jetson nano. If the driver portion is ready I’d be more than happy to test it out for you. I have a nano B01, Rapi camera HQ v1.0 with R8 resistor removed.

2 Likes

I was able to follow the complete installation process but exactly the intructions with moving the kernel modules from tmp to /lib/modules/ seems to be not correct. The original image contains already a folder called 4.9.140-tegra . note tegra with lower case t. if i follow exactly your mv command sudo mv /tmp/4.9.140/* /lib/modules/4.9.140-Tegra/ i get … no directory error message. if i remove the * it results in two folders in /lib/modules/ 4.9.140-Tegra and 4.9.140-tegra. but boot failed with blinker because kernel modules could not be started. I also tried to remove the original kernel modul folders and moved the new one into a folder named exactly like the folder from original image. All variants i tried seems to be not able to start kernel modules. If I replace the patched image with the original I can boot again (at least if the modules are in the folder 4.9.140-tegra with lower case t. Unfortunately I do not have any idear to bring it to work at moment. I hope someone can give me a hint in the right direction.
Only to be clear my hardware is a Xavier NX developer kit.

I think there is a problem on this thread mixing Nano with NX. I think the driver and steps are for Xavier NX and it is not released for Nano, NX and Nano are different boards, with different ISP

So the drivers aren’t compatible with Nano as far as I understand. I will wait for the specific driver for the nano then as well.

I made all this test on Xavier NX developer kit. So it should work. Probably I’m missing an important detail. All installation steps from the wiki runing smoothly exact as described in the wiki besides of the last step concerning the mv command from the kernel modules and this seems the problem during boot with error message ‘could not start kernel modules’ .

1 Like

Hi All,

I think this post is becoming too big. As you mentioned the driver is currently supported in Jetson NX and we are working to support it in Jetson Nano as well. For this reason I created two posts to keep the conversations organized.

Please let us know your questions and results with the driver. We will try to provide guidance. Also, we know others have been able to use the driver, feel free to help others as well in those two posts.

-David

5 Likes

Locking this topic now to direct further posts to the new topics that David created above. Thanks for the great support @DavidSoto-RidgeRun!

4 Likes