RAW Sensor get error gstnvarguscamerasrc.cpp, execute:645 No cameras available

Hi NV_Team,

We are using a gmsl raw sensor implement on Jetson NX, v4l2-ctl works fine, but gst+nvarguscamerasrc get an error “execute:645 No cameras available”. Please help give some advice (using JetPack4.5).

How does nvarguscamerasrc get the camera device available?

nvidia@nx:~$ gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! 'video/x-raw(memory:NVMM), width=(int)1928,height=(int)1208' ! nvvidconv flip-method=0 ! 'video/x-raw, format=(string)I420' ! xvimagesink -e
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:645 No cameras available
(gst-launch-1.0:9349): GStreamer-CRITICAL **: 10:33:21.298: gst_mini_object_set_qdata: assertion 'object != NULL' failed
Got EOS from element "pipeline0".
Execution ended after 0:00:00.216551334
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
nvidia@nx:~$ v4l2-ctl  -V --set-fmt-video width=1928,height=1208,pixelformat=BA12 --set-ctrl bypass_mode=0 --stream-mmap --stream-count=1 --stream-to=fzcam.raw  -d /dev/video0

Format Video Capture:
	Width/Height      : 1928/1208
	Pixel Format      : 'BA12' (12-bit Bayer GRGR/BGBG)
	Field             : None
	Bytes per Line    : 3856
	Size Image        : 4658048
	Colorspace        : sRGB
	Transfer Function : Default (maps to sRGB)
	YCbCr/HSV Encoding: Default (maps to ITU-R 601)
	Quantization      : Default (maps to Full Range)
	Flags             : 
<
nvidia@nx:~$ dmesg |grep bound
[    4.030563] tegra194-vi5 15c10000.vi: subdev fzcam 0-001a bound
[    4.030590] tegra194-vi5 15c10000.vi: subdev 15a00000.nvcsi--2 bound
[    4.031326] tegra194-vi5 15c10000.vi: subdev 15a00000.nvcsi--1 bound
nvidia@nx:~$ v4l2-ctl --list-devices
vi-output, fzcam 0-001a (platform:15c10000.vi:0):
	/dev/video0

nvidia@nx:~$ dmesg | grep -i fzcam
[    2.057160] fzcam 0-001a: probing v4l2 sensor.
[    2.057845] fzcam 0-001a: tegracam sensor driver:fzcam_v2.0.6
[    2.446152] fzcam 0-001a: Detected FZCAM sensor

Thanks.

hello Luna2020,

this usually the error reported by Argus for the camera initialization.
you should review the device tree properties since those were value for Argus, please also try config all the clock to maximum for testing.
thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.