Rtx 2070 Super, debian buster (10), x works fine, but no gpu "found" by other programs, including the ones from nvidia

No 2070 super found even by some nvidia programs. graphics and x menu work fine. can’t get any GPU programs to even see the board!

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Bear in mind that I was forced to load the 440.something drivers from Buster backports as loading the drivers from nvidia site broke BOINC and every other program in use, except X.
*nvidia-bug-report.log (1.6 MB) * reinstall of OS and all was required.

Looks fine. What exactly doesn’t work? Did you install libcuda? https://packages.debian.org/search?keywords=libcuda

libcudart9.2 v9.2.148-7 is installed. Nothing works except X for GPU tasks. The nvidia program that shows a text based info for gpu works, but nothing else.

What. exactly. doesn’t. work?
libcudart is the runtime, I asked for libcuda, the driver. Package: libcuda1

The.graphical.menu.X(config).works. The.2.little.text.programs.that.are.from.nvidia.work, except.that.nvtop(?).shows.some.text.based.gpu.memory.used, and the.nvidia.detect-like.program(also text based).works.but.returns.not.found.



Would you like me to repeat this a 4th time?

None of the BOINC gpu-based tasks work.

I did not install libcuda as the package didn’t include it and when I looked at it, it is version 414.something versus libcudart9.2 which was installed by the package installer. 414.something seemed like it is for a much earlier driver version. If it’s compatible with the 440.x driver and is needed, I will install it. I have no way to make a judgement on this decision. I don’t even know the difference between the libcuda1 and the rt version.

Aside: I use Synaptic as it’s much easier to search and load and one can see related files if you get the right search keyword.

You told me that everything was working except something from nvidia that displays something doesn’t work. You told a lot that were completely irrelevant.

None of the BOINC gpu-based tasks work.

Is the only helpful info, so let’s work on that.
Seems that CUDA isn’t working for you. For starters, the needed file layout/chain:
executable (CUDA enabled application)->libcudart.so(the CUDA runtime)->libcuda.so(the CUDA driver)->nvidia.ko/nvidia-uvm.ko(the nvidia kernel driver)
I don’t know how the repo does the packaging and comes up with the package names, so I can’t really say which packages you need.
The kernel modules and libcuda.so come bundled in the nvidia driver.
The runtime (libcudart.so) should come bundled with the application; otherwise, this is provided by the cuda-toolkit from nvidia.
So you will have to find out which package installs libcuda .so.440.64 to get a full driver install. Also find out which package installs nvidia-smi (also normally bundled with the driver), this will display the cuda driver version.
Furthermore, you have a 9.x runtime installed, this is incompatible with RTX cards and newer, please remove those packages.

Ok, packages removed.
I ran nVidia’s installer while in the Live distro so it wouldn’t corrupt the real system. First, I ran it with the -x option from a local hard drive, where I found libcuda.so from 440.84

ok. Wow.
Ran the downloaded nVidia installer, 440.82 (what happened to .84?) NVIDIA-Linux-x86_64-440.82.run.
Anyway, after running the nVidia downloaded driver update, and search for “libcuda” in “/” found:


Tried to copy and paste the files found, but of course, Linux does not cooperate.

Bottom line: it appears the nVidia downloaded installer does NOT place libcuda.so* in the correct locations., nor does it for the libcudart*!!! This is a terrible bug, difficult to find and I find it impossible to determine just WHERE in the filesystem the proper files are supposed to go, ESPECIALLY with so many stupid links.

Still trying to get CUDA drivers on the 2070S up and running. After the failure of the nVidia supplied (huge) script to install them on the buster machine, started searching again.
So, continually confused due to the lack of coherent nVidia documentation, does installing and running the “CUDA toolkit” set everything up so that I may now use this very high dollar graphics card for everything it is touted to do?
And put all the CUDA api’s (libraries) in their proper locations for my particular graphics card?

I don’t really know what you’re complaining about, libcuda is in the correct place:
but you still have the incompatible cuda runtime 9.2 packages installed.
For cuda-toolkit installation from runfile, skip driver installation and afterwards, perform the “post installation steps” from the installation docs:

  1. For example, the only libcudart’s that I see are all the 9.2, which you (generix) said is the wrong version for the RTX boards. Did I miss something?
  2. Should I manually rm each libcudart9.2?
  3. The nvidia toolkit download has ubuntu 18.04 but no reference do Debian 10 Buster. Are they compatible?

The 9.2 cudart files are from a debian repo package you installed at some time. Use apt to uninstall those packages. Those do not come bundled with the nvidia provided driver.
To install the cuda toolkit, you could try if the ubuntu packages work and NOT install ‘cuda’ but use
sudo apt install cuda-toolkit-10-2
use the .run installer BUT skip the driver install when it asks for it. The manually set the correct PATH.