Second Monitor Not Detected in Ubuntu 23.04

I bought a new laptop yesterday and installed Ubuntu 23.04 for dual boot with Windows. No matter what I do, I haven’t yet been able to make Ubuntu detect my second monitor, which I connect through HDMI. After plugging the cable in, the monitor just quickly shows “HDMI NO SIGNAL” after a few seconds and then goes blank again. The monitor is automatically detected in Windows – it works without any problems there.

Some information about my setup:

  • the laptop is HP ZBook Power 15.6 inch G9 Mobile Workstation with NVIDIA RTX A1000 Laptop GPU
  • output of xrandr --listproviders is
Providers: number : 2
Provider 0: id: 0x217 cap: 0x1, Source Output crtcs: 0 outputs: 0 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x23f cap: 0x6, Sink Output, Source Offload crtcs: 4 outputs: 5 associated providers: 1 name:modesetting
  • output of xrandr --listmonitors is
Monitors: 1
 0: +*eDP-1-1 1920/344x1080/194+0+0  eDP-1-1
  • output of dpkg -l | grep -i nvidia
ii  libnvidia-cfg1-535:amd64                         535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-535                             535.54.03-0ubuntu0.23.04.2                all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-535:amd64                      535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA libcompute package
ii  libnvidia-decode-535:amd64                       535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-535:amd64                       535.54.03-0ubuntu0.23.04.2                amd64        NVENC Video Encoding runtime library
ii  libnvidia-extra-535:amd64                        535.54.03-0ubuntu0.23.04.2                amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-535:amd64                         535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-535:amd64                           535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  nvidia-compute-utils-535                         535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA compute utilities
ii  nvidia-dkms-535                                  535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA DKMS package
ii  nvidia-driver-535                                535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA driver metapackage
ii  nvidia-firmware-535-535.54.03                    535.54.03-0ubuntu0.23.04.2                amd64        Firmware files used by the kernel module
ii  nvidia-kernel-common-535                         535.54.03-0ubuntu0.23.04.2                amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-535                         535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA kernel source package
ii  nvidia-prime                                                             all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                                  510.47.03-0ubuntu1                        amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-535                                 535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA driver support binaries
ii  screen-resolution-extra                          0.18.3                                    all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-535                    535.54.03-0ubuntu0.23.04.2                amd64        NVIDIA binary Xorg driver

What I’ve tried (mostly based on information I found on this forum) without any success:

  • sudo prime-select nvidia
  • purging all the NVIDIA drivers and reinstalling them with sudo apt install nvidia-driver-535
  • selecting “NVIDIA (Performance Mode)” in NVIDIA Settings > PRIME Profiles
  • commenting out Option "IgnoreDisplayDevices" "CRT" in /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf and disabling gpu-manager (GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nogpumanager" in /etc/default/grub) to not overwrite the change
  • switch from gdm3 to lightdm using sudo apt install lightdm

Any help would be much appreciated. Thank you.

1 Like