Series 550 freezes laptop

Hello everyone,

I wanted to mention that the problem is not specific to Arch. I also have the same problem with Opensuse Tumbleweed.

My laptop is an Asus Zephyrus G14, with a Ryzen 5900hs and a 3060RTX.

Regularly, I experience complete system freezes:
Often when updating the system. I’ve corrupted my installation but recovered it with a snapshot (thanks btrfs).
Sometimes at startup.
Sometimes at shutdown.
More regularly when using virtual machines (kvm / virt-manager).
And sometimes completely randomly.

The version present on my system (and which, when activated, causes problems) is: 550.78-22.1

The problems occur with both Wayland and X11.
I use KDE 6 and kernel 6.8.8-1.

I’ve had the nvidia driver completely deactivated for 3 days now, before coming across this topic, and I don’t have any freezes at all.

1 Like

I tried Pop Os and with kernel 6.8.0 and nvidia 550.54.14 its stable but I cant get it to work on arch.

Since the launch of 550.76, I’ve switched to the nvidia-open-kernel modules. They are extremely solid and even fixed a lot of the visual bugs I had. Power management works, dGPU turns off on battery and power limits are set accordingly on AC.

3 Likes

Does hardware acceleration in chromium based programs work for you? My stderr gets spammed with EGL_BAD_ALLOC whenever I launch chromium. The nvidia-open-dkms doesn’t cause my laptop to panic whenever I draw a little too much power, but it is frustrating loosing out on hardware acceleration- especially since the cpu draws loads of power when I’m off the outlet.

I think the freezing is related to some power management issue- I’ve noticed that when I run my laptop in the quiet ACPI platform profile, I am able to use the dedicated gpu just fine and my laptop doesn’t seize up, however, when switching to balanced or performance, my laptop will freeze almost immediately.

(echo performance | sudo tee /sys/firmware/acpi/platform_profile)

I did a fresh install today of arch with the latest nvidia drivers. Everything is working flawlessly now

Hi. What card or cards do you have?
I have on Manjaro with the latest drivers (550.78) and kernels (6.6 and 6.9) and updates still glitches. I have hybrid graphics (4080 + Intel).

Arch Linux
Acer Predator Helios 300
GeForce 3080 + Intel
kernel 6.8.9-arch1-2
drivers nvidia-open-550.78-2;
kernel boot flags: nvidia_drm.modeset=1
Wayland with external monitor.

Second day works without freezes.

1 Like

I’ve been working on the open source driver since this morning.

I haven’t had any freezes comparable to those I have on the proprietary driver.

But with the open-source driver, I have a systematic crash when I resume from standby. The graphics server won’t start.

When I go to console 1, and do a dmesg, I get lots of messages:

NVRM: kbusVerifyBar2_GM107: MMUTest BAR0 window offset 0x70e000 returned garbage 0x0.

When I try to go to console 2, I find my desktop from before the standby and the PC is completely frozen. Impossible to return to console 1 or do anything.

In short, for me it’s unusable, because the PC is a laptop and I use it on the move. When I’m on the move, it’s often (always?) on standby.

As a reminder, I’m on Opensuse Tumbleweed, kernel 6.8.8-1-default, kde6 and the version I tried was 550.78 open.

It would be nice to have a little more conclusive feedback from nvidia. We have a bug that creates file system corruptions, several of us are affected and the first message dates back to March 3, so 80 days … almost 3 months.

2 Likes

I must say I don’t use sleep, because it always was a headache on Linux with Nvidia.

I’m using proprietary drivers :(
I’ll try to switch to open

1 Like

It’s been a long, long time, years in fact, since I’ve had a standby problem.

Even on my Nvidia-equipped machines.

Here, the problem is specific to the open source driver. With the proprietary driver or without any Nvidia driver, I have no standby issues.

I got a 4070 mobile. Its in a msi laptop. Im running the latest arch kernel 6.8.9-arch1-2 the nvidia drivers are stable with 550.78. The only thing i noticed on system shutdowns the kernel will sometimes panic and hang. I was able to bypass that by just installing bumblebee and bbswitch

2 Likes
  • Legion 7 (16achg6)
  • RTX 3070
  • AMD Ryzen 7 5800H (iGPU turned off using bios mux switch, I don’t have any prime/optimus manager installed)
  • 32GB Ram
  • Linux Kernel 6.9.1-arch1-1
  • Nvidia driver version: 550.78
  • KDE Plasma 6.0.4
  • Vanilla arch with barely anything installed. Nvidia packages installed are:
    lib32-nvidia-utils 550.78-1, nvidia 550.78-4, nvidia-settings 550.78-1, nvidia-utils 550.78-1

So just as I was typing out that the new updates have made crashes less frequent, I just experienced one… Heres what I did:
I launched a game on steam, which started the vulkan shaders processing. My cpu shot up to 100%, and gpu shot up to around 30% usage.
Then I closed the game because my cpu temperatures were going waaaay up (I have to repaste my cpu/gpu soon) and issued a ‘poweroff’ command in the terminal to cool my system down fast.
As soon as I issued that command, my whole computer froze. I wasn’t able to use the REISUB magic sysrq keys either. No logs came up, nothing. Was stuck on this screen until I forcefully shut down my laptop by holding the powerbutton.

(you can see behind the terminal the gpu/cpu spikes)

Immediately after restarting, I tried reproducing this and recording it, trying what I mentioned above and I was not able to crash the system like this again. However, I believe that this has something to do with the uptime of the system as all the previous crashes I’ve had more or less follows the same pattern: system uptime is longer than 8 hours (with system going into suspend multiple times in between) → open resource intensive application and try alt tabbing, powering off computer or similar → system crashes.
I’m even more positive that it has to do with the system uptime as a lot of previous posts mention something related to this.

I will try to reproduce this again tomorrow and hopefully capture it on camera if I’m able to. I’m also not sure what logs to provide here since I rebooted so many times and journalctl is filled with logs, so if anyone could guide me with this I’d be more than happy to post some logs too.

I hope nvidia fixes this soon :)

as a side note;
is the nvidia-open-dkms any less performant than the proprietary one? I would like to try it out but I’m worried it might be missing some features that the propreitary one has (i.e. lower performance, g-sync, etc etc).

Could anyone confirm or deny this please?

i am on a legion too the 15ach6h(r5 3600 and rtx3060), and i’ve reinstalled endeavourOS a third time, now with nvidia-open on mainline kernel, and its been working quite well, except with external displays, kwin crash a bit easier(not all the time, just tried now did not crash tho) and at waking from suspend and when the external display is being used, the device takes longer to show the login screen(sddm), all a non-issue i’d say if you rarely or don’t use at all external displays.

Nothing different apart from that that i noticed ever since, performance seems quite the same, powerd-service works well, and s3 idle sleep to gpu too, i’ve got disabled the -supend, -hibernate, and -resume daemons however.

The package i installed was nvidia-open from arch repo.

In conclusion if this stays as stable as is, its well worth the tradeoff, also since nvidia will be making the openkm the main priority i can only expect the drivers to get even better and more stable than ever in linux history.

1 Like

3070M, three days ago installed 550 nvidia-open-dkms via nvidia-all instead of the last 535, g-sync works, no crashes (as I wrote at the beginning of the thread), sleep fixed, but games via Wayland under KDE are not too playable either (waiting for KDE 6.1)

1 Like

Interesting… are you sure g-sync is working as expected?

https://download.nvidia.com/XFree86/Linux-x86_64/550.78/README/kernel_open.html

The following features are not yet supported by the open kernel modules:
G-Sync on notebooks

I’ve switched over to nvidia-open recently and will try out the g-sync as well and see if it works or not. What laptop do you have btw?

I am using an external monitor AOC Q27G2S/EU, I haven’t tried with the built-in monitor (Redmi G Pro i9-12900H laptop). Nothing worth trying to install nvidia-open and roll back to the proprietary driver if you are not satisfied with it (if there are any problems, it can be done via tty with nvidia-all)

I have to say that I got freezes again, but they become rare. Zero freezes was on 535.171.04 and kernel 6.8.7

Havent had any problems with 555 beta yet.

1 Like

I updated my laptop to nvidia 555.42.02 and …


I use the kernel 6.9.1.arch1-1
I have a GTX 1060 then I can’t use the open source driver.

1 Like