Set Up Axis to "z" not "y"

I am coming from Blender and I am very used to the up axis being “Z” not “Y” as is the case in Nvidia Omniverse Code.
In order to work more efficiently I want to change the up axis to"Z".
Please does anyone know how to go about it?

@inkman.illustrator the default axis orientation vary from app to app, but it’s fairly straight forward to change it. below are two examples of OV apps where they may differ:

  • Code - Y-up
  • Isaac Sim - Z-up

to check which axis orientation you are using in your USD stage, you can always confirm it via the gizmo at the bottom left of the Viewport panel, which i am sure you’ve seen:


so, how do we change it? there are at least two ways to set up your scene’s axis orientation:

  • in your OV app preferences - this should change the behavior of the default file behavior whenever you create a new USD file. open up the Preferences panel then Stage > Default Up Axis

  • in your layer property - each USD file has its inherit axis orientation. so, if your pipeline involves using the Layer panel to set up your scene with other USDs; or, if you are wanting to change the axis orientation of an opened USD file, change the World Axis param inside Layer Metadata while you have the Root Layer selected:

1 Like

It worked.
Thanks so much.
I really appreciate it.

1 Like

You can also do it programmatically. Here’s a link to the snippet: Set the Stage Up Axis — Omniverse Developer Guide latest documentation


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.