[SOLVED] Access denied trying to register a new account

Searching through the forums it seems this is an old ongoing issue. I have found posts from 2013. It hasn’t been already fixed?

This is what I get when attempting to create a new account on the https://developer.nvidia.com/user/register page, after completing the form and pressing “Create New Account”:

Access Denied
You don’t have permission to access “http://developer.nvidia.com/user/register” on this server.
Reference #18.acfb3d17.1394410633.af839fb

tried with both FF and Chrome, so it’s not a browser issue.

UPDATE: The solution is to stick to lower case letters in the e-mail address.

We’re sorry the site is not working as expected and thanks for bringing the issue to our attention.

Unfortunately, we are unable to reproduce the issue. Can you send me a private message with the following information.

  1. Step by step reproduction instructions
  2. email used to sign up
  3. user name used to sign up

Thanks for your help!

I’ve sent a message to EricFoo, no answer after three days. No idea why I’m always expecting more than people are used to offer.

Anyway, for everyone stumbling upon the same problem, keep to lower case letters in your e-mail address when registering. If you use anything else, you’ll hit this bug.

MoonStorm, please see the private message I just sent.

Thanks to your notification on the issue, we discovered a corner case in our registration system that fails. We have been working on a fix and have just deployed it along with a brand new site revamp of Developer Zone.

Please visit http://developer.nvidia.com to discover the new developer zone!