[SOLVED]It cracks with kernel 4.16.16 in Debian.

With the drivers for the GeForce GT8600M, with the version 340.107, I can say very much, so right now, if I install the new version of the kernel of Linux, compiled by Debian, it provokes that there is blocked the whole system (fortunately, I have the SysRq activated for these things).

That’s why, always I resort to the Downgrade of the version, to which it had previously (fortunately, I always appeal this with snapshot.debian.org)

I give the report of bug of the same one, because in the version 4.16.12, it does not fail for anything. But yes in 4.16.16.

Thanks.
nvidia-bug-report.log.gz (88.6 KB)

Nothing? Not solutions?

It does not work already in the version 4.17. For nothing already.

I am sorry that the things could not be done like ancient. This laptop will end up by being already a relic definitely.

I have to be content with Nouveau, meanwhile.

The solution is add on the file /etc/default/grub in the line:

GRUB_CMDLINE_LINUX=“video.allow_duplicates=1 slab_common.usercopy_fallback=y”

Only adding:

slab_common.usercopy_fallback=y

Outing using:

update-grub

Yeah! WORKING. :-)

I can confirm this is indeed an issue with the driver with kernel 4.16. This Debian BTS entry also discusses the problem: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=899201

Adding slab_common.usercopy_fallback=y as a workaround worked for me also, but I’d appreciate if nVidia can come up with a proper fix in the long run.

I know it @perlum, this way I have done it.

Only to put this parameter to the file/etc/default/grub.

In this moment NOT PROBLEM. ;-)

Thanks.

Well, it’s more of a workaround than a proper solution. This is a bug in the driver that should be fixed so that it supports kernel 4.16+.

(Unfortunately, the Linux kernel module API is not stable which is discussed further here: https://github.com/torvalds/linux/blob/master/Documentation/process/stable-api-nonsense.rst)

Best regards,
Per

The proper fix for that has already been mentioned by aplattner of nvidia here:
https://devtalk.nvidia.com/default/topic/1031067/linux/-linux416-nvidia-390-48-nvidia_stack_cache-rip-0010-usercopy_warn-0x7e-0xa0/post/5255457/#5255457
and resulted in a patch here:
https://devtalk.nvidia.com/default/topic/1030082/kernel-4-16-rc1-breaks-latest-drivers-unknown-symbol-swiotlb_map_sg_attrs-/?offset=29#5267722
Only question left is why nvidia devs didn’t care to implement it in the last 4 months.

Thanks generix. :-) In my case is worked on Debian SID.

Thanks.

Thanks for the links @generix. Agree, it feels a bit sloppy on nVidias part if this has been a known issue for 4 months. We shouldn’t have to enable these quirks in the Linux startup parameters really.