[Solved] Weird ray generation hang (really simple code)

So I turns out that the small sample I made works on my friend’s old laptop with 8600M GT gpu (had to compile for “compute_11,sm_11”). So it seems like a driver issue.

I’d really appreciate if someone could try run the sample in the link below and tell me if they see “Launched Successfully” at the end + their GPU/driver:

compute_20,sm_20 version:
64 bit http://ge.tt/5AmNPck1/v/0?c
32 bit http://ge.tt/18ZFPck1/v/0?c

compute_11,sm_11 version:
64 bit http://ge.tt/8gJbSck1/v/0
32 bit http://ge.tt/6TjsVck1/v/0?c

It’s not a malicious file as browsers seem to think for some reason. To download in Google Chrome you need to uncheck “Enable phishing and malware protection” toggle in “Settings -> Show advanced settings”

I’d like to know which GPUs don’t suffer from this issue, I’ll just get one of those, I need it working…

Really? No one to try? Don’t even have to compile…
@Detlef What’s the status? Has this been reviewed, accepted us a bug? What is the bug?

So far it worked only on old gpus:
GeForce 8600M GT, driver 335.23
Quadro FX 1600M, driver 334.95

Didn’t work on:
GeForce GTX 770, driver 337.88
GeForce GT 525M, driver 337.88
GeForce GTX 760, driver 335.23
Quadro FX 5800, driver 320.57 (cuda 5.5.1)
GeForce 310, driver 190

Unfortunately I’m unable to access your linked files from within our offices (file sharing sites are blocked by IT) and I won’t be able to look at your github either before next week.
Maybe you notify someone from the OptiX team directly by sending an e-mail to OptiX-Help.

Soo… found the problem. Ridiculously simple. When setting the miss program I used a value from RayType enum not EntryPoint enum. Therefore the miss program wasn’t called for given ray type, stopping condition wasn’t set and an infinite loop started.

All the weird ways context crashed really confused and misled me. Why would there be issue with rtPrintf in this case?
If I would have seen a bit of decent debug output I would have realized this much much earlier. I had increased print buffer to 10 MB already a while hoping that would help get some output in case of an infinite loop.