Tensorflow 1.6 not working with Jetpack 3.2

Hi,

This is an example for your reference:
https://github.com/jhjin/tensorflow-cpp/blob/master/app.cc#L96

Thanks.

I belive this issue is related to our issue:
https://devtalk.nvidia.com/default/topic/1036339/jetson-tx2/tensorflow-fails-to-create-a-session-and-issue-with-docker/post/5269439/?offset=10#5269464

And it is not fixed by changing the allow_growth, it just hides the problem until it happens again, there is something wrong in the memory allocation and it happens both in CUDA 8 and 9.

The thing is that it doesn’t happen all the time that is why you might think that something you did fixes it but in reality it doesn’t.

Hi,

Jetson and aarch64 is not officially supported by TensorFlow.

There is a known CUDA issue and the detail can be found in the topic you shared:
https://devtalk.nvidia.com/default/topic/1036339/jetson-tx2/tensorflow-fails-to-create-a-session-and-issue-with-docker/post/5269439/?offset=10#5269464
The WAR is to use allow_growth configuration and the fix will be available in our next CUDA library.

We know there are some issues inside TensorFlow but it shoukld be fixed by the TensorFlower.
We monitor the functionality of CUDA driver and libraries, however, it’s not possible for us to check all the third-party code on GPU.
It’s recommended to post you concern and requirement to their GitHub:
https://github.com/tensorflow/tensorflow/issues

Thanks.

worked perfectly for me too.
Big thanks NVIDIA team !

Thanks @AastaLLL for the solution for C++ API. Is it solve for JetPack 4.1, with CUDA 10?