Tensorflow doesn't see any GPU


in case I posted this message in wrong group, please point me right group.

the issue is - my tensorflow does not see any GPU.

print("Num GPUs Available: ", len(tf.config.list_physical_devices('GPU')))

this code returns 0

could somebody help me to fix it ?


TensorRT Version:
GPU Type: nvidia 2080 ti
Nvidia Driver Version: 528.49
CUDA Version: 12.0
CUDNN Version:
Operating System + Version: Windows 10
Python Version (if applicable): 3.11.0
TensorFlow Version (if applicable): 2.12.0-rc0


Having the same issue here…

Why is it too difficult to activate GPU. I have followed different tutorial, yet same erro.

I am writing this for any seekers in future.

I used different instructions than on official website.

Instead of typing “pip install tensorflow” I typed “conda install tensorflow” (since Miniconda didn’t list tensorflow I decided to install with conda) in Anaconda Powershell.

And it worked! Now TF sees my GPU.

Not enough information in the original to be able to tell exactly what sort of install they’re attempting.

I’m running into a similar problem and working through various different solutions. It used to be simple to get tensorflow to use the native GPU in a system, but not anymore. Even after attempting to install CUDA/cuDNN and validating the installs as well as possible, tensorflow does not see the GPU. I think the problem is that the Windows version stopped looking for it at 2.10 which is now old enough that it’s not readily available for install. It seems we now need to move to WSL which I’m now attempting to do.

While I understand there are a lot of good reasons to go with WSL, it seems like it was so simple before to have my GPU working for me and now I’m needing to put in a lot of extra steps. Will update if/when I get it solved and would appreciate any other input/suggestions.