Tensorflow HELP on Jetson Nano?

Hi everyone! Ive never posted here so plz forgive me for having broken any rules.

I am currently working on a face recognition project using a face detector called FaceBoxes:

https://github.com/veshitala/face-detection.git

After 7 days of torturous installation I finally got tensorflow 2.x to work but when I tried to run the detector I get:

And then the system just FREEZES and after a few minutes I get “Killed” on the Terminal.

I considered the possibility of running out of memory and created a 2GB swap but that didn’t work either.

I ran the SSD Object Detector on TensorRT which seemed to work fine but this model on Tensorflow didnt work. As I understand this detector is not VERY heavy but for some reason its possibly taking up alot of RAM?

I am very new on working with Jetson Nano and also have little ML/DL experience. Any guidance on this would be extremely helpful. Thank You!

EDIT:

I would just like to add that I am NOT PERFORMING ANY TRAINING … JUST INFERENCE.

These are the lines of code for detector:

MODEL_PATH = ‘/model.pb’

face_detector = FaceDetector(MODEL_PATH, gpu_memory_fraction=0.75, visible_device_list=‘0’)

Hi,

TensorFlow might occupy much more CUDA memory for workspace.
Could you help to monitor the system status via tegrastats first?

$ sudo tegrastats

If the issue is cased by the OOM, please try the following suggestion to see if helps first.
TF v1.15.x: Resource Exhausted Error
TF v2.x: Jetson Nano running out of memory: ResourceExhaustedError: OOM when allocating tensor with shape[3,3,512,1024

Thanks.