Ubuntu 20, titan rtx fan speed

nvidia-xconfig --enable-all-gpus
nvidia-xconfig --cool-bits=4

Worked in ubuntu 18, allowing me to manually control fan speed during training using the “NVIDIA X Server Settings” app. My 2 titan rtx run 86C during training. If I manually set the fan to 100%, temp 76C.

Upgraded to ubuntu 20.04, everything very stable except after setting the coolbits=4. When I do, I get manual fan control, but after the screen times out and darkens, I log in, the mouse does not appear. reboot using the T to get a terminal(no mouse), sudo reboot, log in and all is fine until the screen darkens after a timeout.

Delete the /etc/X11/xorg.config, reboot, then all is good again, even after screen times out and darkens, but no GPU fan speed control.

Very repeatable.

Any other way to enable manual fan speed control on NVIDIA?

I tried sudo nvidia-smi --gpu-target-temp=70 but this had no effect on fan speed.