UI Unresponsiveness and Missing Elements Post-Reboot on Jetson Orin NX with JNX42 Board

Hello NVIDIA Developer Community,

I am experiencing a challenging issue with my NVIDIA Jetson Orin NX 16GB module mounted on an Auvidea JNX42M2 carrier board. The system initially operates as expected immediately after flashing with Auvidea’s firmware. However, after the first reboot, the graphical user interface becomes unresponsive to mouse clicks, and the desktop icons disappear.

System Details:

  • Device: NVIDIA Jetson Orin NX 16GB
  • Carrier Board: Auvidea JNX42M2
  • Storage: 256 GB SSD via M.2 slot
  • Firmware Version: Tried both JNXxx v1.2 for JetPack 5.1.2 and JNXxx v1.0 for JetPack 5.1
  • Flashing Host OS: Ubuntu 20.04 OEM

Symptoms Post-Reboot:

  • Desktop icons and taskbar items are not visible.
  • Mouse cursor moves but does not interact with UI elements.

I’ve attached images showing the setup and the screen after rebooting. I’m wondering if anyone else has encountered similar issues or if there are known compatibility concerns with the Auvidea firmware and the Orin NX?

Any guidance on troubleshooting steps, potential solutions, or points to consider would be greatly appreciated.


Please try the following experiments:

  1. Reboot again to see if the behavior is similar.
  2. If the reboot doesn’t help, please remote login via SSH, type sudo dmesg and share the log with us.


1 Like

Interestingly another monitor solved my UI unresponsiveness and missing elements problem

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.