Unable to apt-get update - missing mirror?

I am sorry to ask this stupid question on this sophisticated forum. I am on my Nvidia Jetson TK1 and I am unable to do a successful apt-get update because one of the repositories is not found 404.
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty-proposed/restricted/binary-armhf/Packages 404 Not Found [IP: 91.189.91.14 80]

does anyone know a mirror I may use? I am trying to update my g++ libs so I can compile an application.

thank you for your kindness with a newbie,
Ken N9VV - Naperville IL USA

Hmm it looks like the binary-armhf tree was removed from the server.

Is it listed in your /etc/apt/sources.list? If so, comment it out with a # beginning the line.

Hi,
Can you make sure that you have “restricted” replaced with “universe” in your /etc/apt/sources.list ?
Please try updating after this and do tell what you see.

Was there a resolution to this issue? I, too, am a noob (just got my Jetson this week), and I’m seeing several armhf update errors like this one :
Err http://us.archive.ubuntu.com trusty/universe armhf Packages 404 Not Found [IP: 91.189.91.15 80]

The main repos include only 32bit and 64bit x86 builds, for ARM you need to use post.ubuntu.com.

Generally speaking you shouldn’t need to manually add addresses to sources.list.d.

The following should enable universe and multiverse repositories:

sudo apt-add-repository universe
sudo apt-add-repository multiverse
sudo apt-get update

OK, thanks. I had too many repos added in my list in an attempt to get around another issue. Once I pared it back, this problem went away.

Has anyone noticed that the binary-armhf packages are missing from the repository again? I searched for them on the web and found them here, among other places:

http://www.mirrorservice.org/sites/ceph.com/debian-cuttlefish/dists/trusty/main/binary-armhf/

But I don’t know enough about the format of the /etc/apt/sources.list to write the URL in. Any help would be much appreciated. Thanks.

What repository are you referring to? I think they still are in their normal repository:

http://ports.ubuntu.com/

Thanks for the link. I had the same problem.
Here are my solutions.

OS: ubuntu 14.04 64bit

sudo gedit /etc/apt/sources.list

delete the update source in the file and paste “deb http://www.mirrorservice.org/sites/ceph.com/debian-cuttlefish/ trusty main” and save the file.

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 7EBFDD5D17ED316D

sudo apt-get update

The other sources are not working properly. Because they are lake of the “Packages”, only have “Packages.bz2 and Packages.gz”. Check 10+ sources. Almost the same problem.

Are you talking about your PC or Jetson? In either case I recommend using the official repositories.

The main Ubuntu repositories (archive.ubuntu.com) only include the amd64 and i386 packages. The other architectures are on a different server (ports.ubuntu.com).

You can check what your current default setup is using by running:

cat /etc/apt/sources.list

highsprite , this does not help. Still see (ubuntu 14.04 64bit):

$sudo apt-get update
...
Err http://extras.ubuntu.com trusty/main armhf Packages 404  Not Found [IP: 91.189.92.152 80]
Failed to fetch http://ru.archive.ubuntu.com/ubuntu/dists/trusty-backports/multiverse/binary-armhf/Packages  404  Not Found [IP: 213.180.204.183 80]
Failed to fetch http://security.ubuntu.com/ubuntu/dists/trusty-security/main/binary-armhf/Packages  404  Not Found [IP: 91.189.92.201 80]
Failed to fetch http://www.mirrorservice.org/sites/ceph.com/debian-cuttlefish/dists/trusty/main/binary-amd64/Packages  404  Not Found

and even

Failed to fetch http://dl.google.com/linux/talkplugin/deb/dists/stable/Release  Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

etc

Is it possible to disable armhf-updates but not remove it completely from PC?

I am also having this problem.

For background: I have a Jetson TX1, and initially tried to set up the JetPack 2.1 on a virtual machine on my laptop (using Ubuntu 14.04) while I waited for a Dell Ubuntu 14.04 laptop. I was able to install JetPack fine.

I tried to install JetPack 2.1 on the Dell, and it fails when it tries to install the CUDA tools (since it needs the cross compiler).

I added the following lines to my sources.list file:

deb http://ports.ubuntu.com/ubuntu-ports/ trusty main
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty main

did a ‘sudo apt-get update’, and still got this…

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/trusty/main/binary-armhf/Packages 404 Not Found [IP: 91.189.88.149 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/trusty/universe/binary-armhf/Packages 404 Not Found [IP: 91.189.88.149 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/trusty/restricted/binary-armhf/Packages 404 Not Found [IP: 91.189.88.149 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/trusty/multiverse/binary-armhf/Packages 404 Not Found [IP: 91.189.88.149 80]

W: Failed to fetch http://oem.archive.canonical.com/updates/dists/trusty-oem-sp1/Release Unable to find expected entry ‘public/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://dell.archive.canonical.com/updates/dists/trusty-dell-berlinetta-p/Release Unable to find expected entry ‘public/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://oem.archive.canonical.com/updates/dists/trusty-oem/Release Unable to find expected entry ‘public/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://dell.archive.canonical.com/updates/dists/trusty-dell-biz-vivid-skl/Release Unable to find expected entry ‘public/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/trusty/main/binary-amd64/Packages 404 Not Found [IP: 91.189.88.151 80]

W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/trusty/main/binary-i386/Packages 404 Not Found [IP: 91.189.88.151 80]

W: Failed to fetch http://dell.archive.canonical.com/updates/dists/trusty-dell/Release Unable to find expected entry ‘public/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

I went back to the virtual machine this morning and did a ‘sudo apt-get update’, and had the same problem, even though the JetPack 2.1 is installed on there fine…

Solution for this problem is described here: https://wiki.debian.org/Multiarch/HOWTO

All you need to do is “architecture qualify” all repositories that do not work for all architectures defined in your system.

For example, to restrict packages from archives.ubuntu.com to amd64 and i386, one needs to write:

deb [arch=amd64,i386] http://archive.canonical.com/ubuntu trusty universe

many thanks of Jakub_Nawala. Your note has helped to eliminate an error against which I long fought

fought

many thanks of Jakub_Nawala. Your note has helped to eliminate an error against which I long fought