Unable to determine the device handle for GPU 0000:01:00.0: Not Found

OS: Ubuntu 22.04 LTS
Kernel version: 5.15.0-52-generic
Driver Version: 520.56.06
GPUs: 1xRTX2060M

I got an error upon a power off/power on, while everything was fine earlier after boot I realized that drivers are not registered or they cant be located. At that time, I couldn’t even use the commands like nvidia-smi, etc.

After installing sudo ubuntu-drivers autoinstall, drivers v520 are installed, and I started getting this error message for nvidia-smi

Unable to determine the device handle for GPU 0000:01:00.0: Not Found

Output of ubuntu-driver devices

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001F15sv00001462sd000012B8bc03sc00i00
vendor   : NVIDIA Corporation
model    : TU106M [GeForce RTX 2060 Mobile]
driver   : nvidia-driver-515-open - distro non-free
driver   : nvidia-driver-470-server - distro non-free
driver   : nvidia-driver-520 - distro non-free
driver   : nvidia-driver-510-server - distro non-free
driver   : nvidia-driver-520-open - distro non-free recommended
driver   : nvidia-driver-515 - distro non-free
driver   : nvidia-driver-470 - distro non-free
driver   : nvidia-driver-515-server - distro non-free
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-driver-510 - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

Note that, this machine is MSI-GL65 Leopard laptop and not a desktop. I’ve searched and found solutions to the same/similar error messages with no help so far. After observing

echo >&2 "  ERROR: Kernel configuration is invalid.";		\

I tried to reinstall kernel headers, but the error persisted.

Below is the fresh bug report (generated at the end, after my trials (installing kernel headers, etc.)).
nvidia-bug-report.log.gz (163.1 KB)

I solved the problem by switching to non open-kernel variant from additional drivers as below.


I had the exact same issue and this fix worked for me, thanks.

I had the exactly same issue but after installing the non-open-kernel drivers, the screen turned black, nothing on the screen, but I still could use the ssh, so I tried Nvidia-smi, and it’s showed everything is installed properly I got the Driver version, got CUDA version, but nothing shows on the screen, BTW,I couldn’t enter tty mode. is there anyone who could help me out?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.