Unable to find any processes, regardless of connection and port

Attempting to use Nsight Graphics 2022.6 to profile a game, that’s launched via Steam (in Windows 11 Pro 22H2).

No matter what connection is used (localhost or 192.168.xxx.xxx) and ports to scan (tried default, tried scanning all of them), no processes appear in the Attach window.

Have used netstat to determine which port the game is opening and narrowed the scan around that, but it still draws a blank. Every application is launched as Administrator.

Is this an issue with the use of Steam or am I configuring things incorrectly?

Edit: Just tried Nsight Systems 2023.1.1 and that’s logged everything just fine.

Edit 2: I’m using an RTX 4070 Ti which isn’t on the official supported list of GPUs for Nsight Graphics – would I be correct in assuming that this is the cause of the issue?

Thank you for using Nsight Graphics and I’m sorry you ran into this problem. Looks like you were using Nsight Graphics 2022.6 on a RTX 4070 Ti GPU. We recently added support for this GPU in Nsight Graphics 2022.7. See this page and let us know if you are still experiencing any issues after downloading and trying out the latest version of Nsight Graphics.

Many thanks for the reply. I’ve tried 2022.7 but it’s doing the same thing. It fires up applications no problem (I use the Keep option with Steam) but doesn’t find any processes (parent or child) on any port,

Sorry for getting back to you so late. Are you able to send a repro of your issue if you are still experiencing it? You can send to dwoods@nvidia.com.

Since you were able to successfully profile the game using Nsight Systems, it could also be an issue with the configuration of Nsight Graphics. Make sure that you have followed the correct steps to set up the tool and that you have the latest version installed.