Unable to purchase the course using 100% discount coupon

At my university, I was given a 100% discount coupon to claim this course. The coupon seems to be working, as it’s being applied, but I’m unable to proceed with the purchase after filling in the required information, due to the error “Sorry, there was a problem with your request” or something like that. As I saw in the browser’s network tab, the status code is 500, so the error is on the server side, I would assume.
I need this solved ASAP as I have a deadline for the course completion next Sunday (05.05.2024).

Also, there is no category to post such sort of questions here, so I’ve selected the first CUDA-related one. (I was redirected to this forum from the live support chat)


Welcome to the forums! This issue will require someone from the DLI team to assist.

I have pinged the engineer to help you ASAP.


1 Like

I was finally able to purchase the course, following the steps:

  1. Enter promo code,
  2. Enter required information
  3. Select the PayPal radio button at the bottom of the form.

This is the first time I’ve followed precisely these steps, so I’m not sure if the problem I’ve mentioned was solved. Before that, I did one of the following:

  1. Enter promo code
  2. Press the yellow Paypal button just beneath the promo code input.

OR (after the previous variant fails)

  1. Price stayed at $0 due to the promo code already being applied
  2. Enter the required information and press “Review”