use of Gstreamer pb omxh264dec to reduce latency

Hi everybody,

I 'm trying a gstreamer video flux between rpi2 and kitTX2.It’s work pretty good…

//pi
raspivid -w 640 -h 480 -fps 20 -n -pf baseline -ex auto -o - -t 0 -fl -b 3000000 | gst-launch-1.0 -v fdsrc !  h264parse ! rtph264pay config-interval=1 pt=96 ! udpsink host=169.254.10.2 port=5000
//tx2
gst-launch-1.0 udpsrc port=5000 ! 'application/x-rtp, encoding-name=H264, 
payload=96' ! rtph264depay ! h264parse ! avdec_h264 ! xvimagesink sync=false

Is this tx2’s pipe opimized ? is there another way to have zero latency?

I have trying to use omxh264dec instead of avdec_h264 but I have an error…
like indicate https://devtalk.nvidia.com/default/topic/1046820/rtsp-rtmp-with-gstreamer-on-tx2/

regard’s

Hi,
On TX2, you may try

gst-launch-1.0 udpsrc port=5000 ! 'application/x-rtp, encoding-name=H264, 
payload=96' ! rtph264depay ! h264parse ! nvv4l2decoder ! nvoverlaysink sync=false

Hardware decoding is enabled in nvv4l2decoder plugin. You can use omxh264dec, but we are deprecating omx plugins and suggest use v4l2 plugins.

Hi I will try your proposition.

But with:

nvoverlaysink

it’s produce an image wich isn’t in a window…
So if you realise a capturescreen it isn’t appears on it…
I use it to evaluate latency.

Laurent.

Hi,
Please use nveglglessink to get window-based output.

gst-launch-1.0 udpsrc port=5000 ! 'application/x-rtp, encoding-name=H264, 
payload=96' ! rtph264depay ! h264parse ! nvv4l2decoder ! nvvidconv ! nveglglessink sync=false