Visual artifacts with HDMI port (with DVI adapter) at 1920x1920

Hello all,

I confirmed that the tx2 supports 1920x1920 (goes up to 3840x2160 at 60Hz according to specs), but when I run at 1920x1920 I get green noisy artifacts. I’ve verified the cable and adapter work fine on 1920x1200 displaysl I only have one of these 1920x1920 displays and my other machines have no issue generating a clean 1920x1920 signal for this monitor. I’ve also confirmed that if I change the tx2 video to 1920x1200 the artifacts disappear.

Here are a few photos of the artifacts:

Is this a defect in my tx2 unit? (received yesterday)

The whole point of this project is to use the tx2 with this particular screen, so what else can I try if this is not a jetson defect?

Thank you,
B.

I just did a second test and here is the signal reported by the monitor when connected to my usual desktop (#1) and the Jetson (#2)

Desktop

  • 1920x1920
  • fH: 119.3kHz
  • fV: 60.4Hz
  • fD: 248.0MHz

Jetson

  • 1920x1920
  • fH: 119.3kHz
  • fV: 60.4Hz
  • fD: 248.1MHz

So the only difference is fD being 248.0MHz vs 248.1MHz

I tested the HDMI cable and HDMI->DVI adapter and confirmed they are working fine and there is no noise when generating a 1920x1920 HDMI signal from a GeForce card.

The Jetson seems to be defective. What are my options?

I’m not sure if the Jetson actually supports that mode as the driver is more limited in what it allows versus a desktop PC video card. If this is the case, then RMA won’t fix anything. However, if you want to try RMA, search for RMA near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

Note that the only modes accepted by the Jetson are those reported via the EDID data (one of the wires in the cable used to ask the monitor what its specs are). No other modes are allowed. In the past (this was a long time ago) I remember seeing an issue which was due to some sort of floating point rounding. This makes me wonder if it is the case now:

So the only difference is fD being 248.0MHz vs 248.1MHz

Assuming the same EDID is used, then the only reason for the difference would be rounding error or difference in how the base clocks and multipliers work.

Some artifacts comes from the lacking of bandwidth.

Could you check below node to see if there is any underflow?

sudo cat /sys/kernel/debug/tegradc.0/stats

Also, you point out the pclk is different between Geforce and tegra. It is possible because the drivers are different and it indeed might cause such artifacts.

I would guess display driver may not fully support such resolution.

Thank you all!

linuxdev: What do you mean by “No other modes are allowed”? I remember in the old days you could specify modelines to X to generate signals, is that not possible these days? No way to specify the video signal generated?

WayneWWW: I don’t see any underflow:

nvidia@zf1:~$ sudo cat /sys/kernel/debug/tegradc.0/stats
[sudo] password for nvidia: 
underflows: 0
underflows_a: 0
underflows_b: 0
underflows_c: 0
underflows_d: 0
underflows_h: 0
underflows_t: 0
underflow_frames: 0

It seems strange that the driver would have so much more constrained support than the HW. 1920x1920 is not that high a resolution, even for an embedded system… If it is not possible to generate this signal on the TX2, then its useless for this project.

I’ll look at what information about the signal I can get from the GeForce machine RE EDID info and see where that leads.

Does Jetpack 4.1 support the TX2?

Are there any other driver updates available?

Thanks,
B.

EDID (via the DDC wire) is the automatic way to provide modelines. Currently the drivers will refuse any custom modeline. Unless your monitor provides this directly via EDID no edits are accepted. You might be able to edit some components in the kernel source, though I’m not sure what limitations there are to that.

JetPack4.1 is only for Xavier. It is rumored though that a future release will support both the TX2 and Xavier.

Thanks for the hints.

I must have made an error in my initial report because further investigation shows the GeForce card was actually generating a different signal entirely (no rounding error).

The Jetson chooses the 1920x1920 @ 60hz option, and I want the 1920x1920 @ 30hz mode:

nvidia@zf1:~$ xrandr -q
Screen 0: minimum 8 x 8, current 1920 x 1920, maximum 32767 x 32767
HDMI-0 connected primary 1920x1920+0+0 (normal left inverted right x axis y axis) 480mm x 480mm
   1920x1920     59.96*+  29.94

I can use the 30hz mode and confirm no artifacts:

xrandr --output HDMI-0 --mode 1920x1920 -r 29.94

So I should be great. I used the ModeDebug Option and found there is an appropriate EDID mode:

[    10.639] (II) NVIDIA(GPU-0):   Validating Mode "1920x1920_30":
[    10.639] (II) NVIDIA(GPU-0):     Mode Sources: NVIDIA Predefined, EDID, Detailed
[    10.639] (II) NVIDIA(GPU-0):     1920 x 1920 @ 30 Hz
[    10.639] (II) NVIDIA(GPU-0):       Pixel Clock      : 121.26 MHz
[    10.639] (II) NVIDIA(GPU-0):       HRes, HSyncStart : 1920, 1968
[    10.639] (II) NVIDIA(GPU-0):       HSyncEnd, HTotal : 2000, 2080
[    10.639] (II) NVIDIA(GPU-0):       VRes, VSyncStart : 1920, 1923
[    10.639] (II) NVIDIA(GPU-0):       VSyncEnd, VTotal : 1933, 1947
[    10.639] (II) NVIDIA(GPU-0):       H/V Polarity     : +/+
[    10.639] (II) NVIDIA(GPU-0):     Mode "1920x1920_30" is valid.

I added a “Screen” section to my xorg and thought I was golden:

# Changed by bbogart for EIZO screen
Section "Screen"
        Identifier      "Screen0"
        Device          "Tegra0"
        Option          "MetaModes"     "<b>HDMI-0: 1920x1920_30</b>"
EndSection

Rebooted to find the 60hz mode was still being used!!! This is despite this Xorg log output:

[    10.414] (II) NVIDIA(0): Validated MetaModes:
[    10.414] (II) NVIDIA(0):     "<b>HDMI-0:1920x1920_30</b>"
[    10.414] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1920
[    10.416] (--) NVIDIA(0): DPI set to (101, 101); computed from "UseEdidDpi" X config
[    10.416] (--) NVIDIA(0):     option
[    10.416] (--) Depth 24 pixmap format is 32 bpp
[    10.417] (II) NVIDIA: Reserving 49152.00 MB of virtual memory for indirect memory
[    10.417] (II) NVIDIA:     access.
[    10.421] (EE) NVIDIA(0): Failed to allocate NVIDIA Error Handler
<snip>
[    10.465] (II) NVIDIA(0): Setting mode "<b>HDMI-0:1920x1920_30</b>"
[    11.743] (==) NVIDIA(0): Disabling shared memory pixmaps
<snip>
[    15.983] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): connected
[    15.983] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): External TMDS
[    16.564] (II) NVIDIA(0): Setting mode "HDMI-0: nvidia-auto-select @1920x1920 +0+0 {ViewPortIn=1920x1920, ViewPortOut=1920x1920+0+0}"

What is with nvidia-auto-select coming back to undo my selection of a validated mode?

Ok, I can’t explain why, but installing xubuntu-desktop and removing ubuntu-desktop has lead to a reboot with the proper resolution (30hz).

[    18.332] (II) NVIDIA(0): Setting mode "HDMI-0:1920x1920_30"

If there is no underflow found, I would guess this artifact comes from a pclk that is not as precise as the mode from EDID.

This may not be fixed on rel-28 based release anymore.

turns out the GeForce card was ‘smart’ enough to switch from 60hz to 30hz when I switched from DVI to HDMI. So the question is why the Jetson validated the 60hz mode when it requires a dual link DVI connection.

Could you elaborate what is the situation now?

Do you set the desired mode successfully?

As I wrote above. I set the appropriate resolution in the xorg, rebooted (pr maybe I only restarted X) and it did not stick. Then I installed xfce4 and rebooted, then the 30Hz resolution did stick. I thought maybe xrandr display settings in xfce4 was the cause, but the xorg log seems to indicate the proper resolution is selected before xfce starts. I probably only restarted X, and a reboot was needed. See the 1920x1920_30 mode below in bold:

[    10.643] 
X.Org X Server 1.18.4
Release Date: 2016-07-19
[    10.643] X Protocol Version 11, Revision 0
[    10.643] Build Operating System: Linux 4.4.0-131-generic aarch64 Ubuntu
[    10.643] Current Operating System: Linux zf1 4.4.38-tegra #1 SMP PREEMPT Thu May 17 00:15:19 PDT 2018 aarch64
[    10.643] Kernel command line: root=/dev/mmcblk0p1 rw rootwait console=ttyS0,115200n8 console=tty0 OS=l4t fbcon=map:0 net.ifnames=0 memtype=0 video=tegrafb no_console_suspend=1 earlycon=uart8250,mmio32,0x03100000 nvdumper_reserved=0x2772e0000 gpt tegra_fbmem2=0x140000@0x969ee000 lut_mem2=0x2008@0x969eb000 tegraid=18.1.2.0.0 tegra_keep_boot_clocks maxcpus=6 boot.slot_suffix= boot.ratchetvalues=0.2.1 androidboot.serialno=0423918014471 bl_prof_dataptr=0x10000@0x277040000 sdhci_tegra.en_boot_part_access=1 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4
[    10.643] Build Date: 10 August 2018  12:01:21PM
[    10.643] xorg-server 2:1.18.4-0ubuntu0.8 (For technical support please see http://www.ubuntu.com/support) 
[    10.643] Current version of pixman: 0.33.6
[    10.643] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    10.643] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    10.643] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 18 19:00:08 2019
[    10.645] (==) Using config file: "/etc/X11/xorg.conf"
[    10.645] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    10.648] (==) No Layout section.  Using the first Screen section.
[    10.648] (**) |-->Screen "Screen0" (0)
[    10.648] (**) |   |-->Monitor "<default monitor>"
[    10.648] (**) |   |-->Device "Tegra0"
[    10.648] (==) No monitor specified for screen "Screen0".
	Using a default monitor configuration.
[    10.648] (==) Automatically adding devices
[    10.648] (==) Automatically enabling devices
[    10.648] (==) Automatically adding GPU devices
[    10.648] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    10.651] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    10.651] 	Entry deleted from font path.
[    10.651] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    10.651] 	Entry deleted from font path.
[    10.651] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    10.651] 	Entry deleted from font path.
[    10.652] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    10.652] 	Entry deleted from font path.
[    10.652] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    10.652] 	Entry deleted from font path.
[    10.652] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/Type1,
	built-ins
[    10.652] (==) ModulePath set to "/usr/lib/aarch64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    10.652] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    10.652] (II) Loader magic: 0x55807ecd80
[    10.652] (II) Module ABI versions:
[    10.652] 	X.Org ANSI C Emulation: 0.4
[    10.652] 	X.Org Video Driver: 20.0
[    10.652] 	X.Org XInput driver : 22.1
[    10.652] 	X.Org Server Extension : 9.0
[    10.653] (++) using VT number 7

[    10.653] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    10.653] (II) no primary bus or device found
[    10.653] (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
[    10.653] (II) "glx" will be loaded by default.
[    10.653] (II) LoadModule: "extmod"
[    10.653] (II) Module "extmod" already built-in
[    10.653] (II) LoadModule: "glx"
[    10.654] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    10.770] (II) Module glx: vendor="NVIDIA Corporation"
[    10.780] 	compiled for 4.0.2, module version = 1.0.0
[    10.780] 	Module class: X.Org Server Extension
[    10.780] (II) NVIDIA GLX Module  28.2.1  Release Build  (integ_stage_rel)  (buildbrain@mobile-u64-773)  Thu May 17 00:15:24 PDT 2018
[    10.780] (II) LoadModule: "nvidia"
[    10.797] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    10.815] (II) Module nvidia: vendor="NVIDIA Corporation"
[    10.815] 	compiled for 4.0.2, module version = 1.0.0
[    10.815] 	Module class: X.Org Video Driver
[    10.816] (II) NVIDIA dlloader X Driver  28.2.1  Release Build  (integ_stage_rel)  (buildbrain@mobile-u64-773)  Thu May 17 00:16:09 PDT 2018
[    10.816] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    10.853] (WW) Falling back to old probe method for NVIDIA
[    10.853] (II) Loading sub module "fb"
[    10.853] (II) LoadModule: "fb"
[    10.853] (II) Loading /usr/lib/xorg/modules/libfb.so
[    10.865] (II) Module fb: vendor="X.Org Foundation"
[    10.865] 	compiled for 1.18.4, module version = 1.0.0
[    10.865] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    10.865] (II) Loading sub module "wfb"
[    10.865] (II) LoadModule: "wfb"
[    10.866] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    10.867] (II) Module wfb: vendor="X.Org Foundation"
[    10.867] 	compiled for 1.18.4, module version = 1.0.0
[    10.867] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    10.867] (II) Loading sub module "ramdac"
[    10.867] (II) LoadModule: "ramdac"
[    10.867] (II) Module "ramdac" already built-in
[    10.869] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    10.869] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    10.869] (==) NVIDIA(0): RGB weight 888
[    10.869] (==) NVIDIA(0): Default visual is TrueColor
[    10.869] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    10.869] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration" "true"
[    10.869] (**) NVIDIA(0): Option "MetaModes" "HDMI-0: 1920x1920_30"
[    10.870] (**) NVIDIA(0): Enabling 2D acceleration
[    10.871] (--) NVIDIA(0): Valid display device(s) on GPU-0 at SoC
[    10.871] (--) NVIDIA(0):     DFP-0
[    10.872] (II) NVIDIA(0): NVIDIA GPU NVIDIA Tegra X2 (nvgpu) (GP10B) at SoC (GPU-0)
[    10.872] (--) NVIDIA(0): Memory: 8041484 kBytes
[    10.872] (--) NVIDIA(0): VideoBIOS: 
[    10.872] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): connected
[    10.872] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): External TMDS
[    10.879] (II) NVIDIA(0): Validated MetaModes:
[    10.880] (II) NVIDIA(0):     "HDMI-0:1920x1920_30"
[    10.880] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1920
[    10.881] (--) NVIDIA(0): DPI set to (101, 101); computed from "UseEdidDpi" X config
[    10.881] (--) NVIDIA(0):     option
[    10.881] (--) Depth 24 pixmap format is 32 bpp
[    10.882] (II) NVIDIA: Reserving 49152.00 MB of virtual memory for indirect memory
[    10.882] (II) NVIDIA:     access.
[    10.886] (EE) NVIDIA(0): Failed to allocate NVIDIA Error Handler
[    10.886] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    10.886] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    10.886] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    10.886] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    10.886] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    10.886] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    10.886] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    10.886] (II) NVIDIA(0):     Config Options in the README.
[    10.928] (II) NVIDIA(0): <b>Setting mode "HDMI-0:1920x1920_30"</b>
[    12.168] (==) NVIDIA(0): Disabling shared memory pixmaps
[    12.168] (==) NVIDIA(0): Backing store enabled
[    12.168] (==) NVIDIA(0): Silken mouse enabled
[    12.215] (==) NVIDIA(0): DPMS enabled
[    12.215] (WW) NVIDIA(0): Option "NoLogo" is not used
[    12.216] (II) Loading sub module "dri2"
[    12.216] (II) LoadModule: "dri2"
[    12.216] (II) Module "dri2" already built-in
[    12.216] (II) NVIDIA(0): [DRI2] Setup complete
[    12.217] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    12.285] (--) RandR disabled
[    12.298] (II) SELinux: Disabled on system
[    12.299] (II) Initializing extension GLX
[    12.300] (II) Indirect GLX disabled.
[    12.614] (II) config/udev: Adding input device tegra-hda HDMI/DP,pcm=3 (/dev/input/event0)
[    12.614] (II) No input driver specified, ignoring this device.
[    12.614] (II) This device may have been added with another device file.
[    12.615] (II) config/udev: Adding input device tegra-hda HDMI/DP,pcm=7 (/dev/input/event1)
[    12.615] (II) No input driver specified, ignoring this device.
[    12.615] (II) This device may have been added with another device file.
[    12.615] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event4)
[    12.616] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[    12.616] (II) LoadModule: "evdev"
[    12.618] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    12.621] (II) Module evdev: vendor="X.Org Foundation"
[    12.621] 	compiled for 1.18.1, module version = 2.10.1
[    12.621] 	Module class: X.Org XInput Driver
[    12.621] 	ABI class: X.Org XInput driver, version 22.1
[    12.621] (II) Using input driver 'evdev' for 'Logitech USB-PS/2 Optical Mouse'
[    12.621] (**) Logitech USB-PS/2 Optical Mouse: always reports core events
[    12.622] (**) evdev: Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event4"
[    12.676] (--) evdev: Logitech USB-PS/2 Optical Mouse: Vendor 0x46d Product 0xc040
[    12.676] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found 12 mouse buttons
[    12.676] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
[    12.676] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found relative axes
[    12.676] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
[    12.676] (II) evdev: Logitech USB-PS/2 Optical Mouse: Configuring as mouse
[    12.676] (II) evdev: Logitech USB-PS/2 Optical Mouse: Adding scrollwheel support
[    12.676] (**) evdev: Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
[    12.676] (**) evdev: Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    12.676] (**) Option "config_info" "udev:/sys/devices/3530000.xhci/usb1/1-1/1-1:1.0/0003:046D:C040.0001/input/input4/event4"
[    12.676] (II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE, id 6)
[    12.676] (II) evdev: Logitech USB-PS/2 Optical Mouse: initialized for relative axes.
[    12.677] (**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
[    12.677] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration profile 0
[    12.677] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration factor: 2.000
[    12.677] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration threshold: 4
[    12.678] (II) config/udev: Adding input device gpio-keys (/dev/input/event3)
[    12.678] (**) gpio-keys: Applying InputClass "evdev keyboard catchall"
[    12.679] (II) Using input driver 'evdev' for 'gpio-keys'
[    12.679] (**) gpio-keys: always reports core events
[    12.679] (**) evdev: gpio-keys: Device: "/dev/input/event3"
[    12.679] (--) evdev: gpio-keys: Vendor 0x1 Product 0x1
[    12.679] (--) evdev: gpio-keys: Found keys
[    12.679] (II) evdev: gpio-keys: Configuring as keyboard
[    12.679] (**) Option "config_info" "udev:/sys/devices/gpio-keys/input/input3/event3"
[    12.679] (II) XINPUT: Adding extended input device "gpio-keys" (type: KEYBOARD, id 7)
[    12.679] (**) Option "xkb_rules" "evdev"
[    12.679] (**) Option "xkb_model" "pc105"
[    12.679] (**) Option "xkb_layout" "us"
[    12.681] (II) config/udev: Adding input device tegra-snd-t186ref-mobile-rt565x Headphone Jack (/dev/input/event2)
[    12.681] (**) tegra-snd-t186ref-mobile-rt565x Headphone Jack: Applying InputClass "evdev keyboard catchall"
[    12.681] (II) Using input driver 'evdev' for 'tegra-snd-t186ref-mobile-rt565x Headphone Jack'
[    12.681] (**) tegra-snd-t186ref-mobile-rt565x Headphone Jack: always reports core events
[    12.681] (**) evdev: tegra-snd-t186ref-mobile-rt565x Headphone Jack: Device: "/dev/input/event2"
[    12.681] (--) evdev: tegra-snd-t186ref-mobile-rt565x Headphone Jack: Vendor 0 Product 0
[    12.681] (--) evdev: tegra-snd-t186ref-mobile-rt565x Headphone Jack: Found keys
[    12.681] (II) evdev: tegra-snd-t186ref-mobile-rt565x Headphone Jack: Configuring as keyboard
[    12.681] (**) Option "config_info" "udev:/sys/devices/sound/sound/card1/input2/event2"
[    12.681] (II) XINPUT: Adding extended input device "tegra-snd-t186ref-mobile-rt565x Headphone Jack" (type: KEYBOARD, id 8)
[    12.681] (**) Option "xkb_rules" "evdev"
[    12.681] (**) Option "xkb_model" "pc105"
[    12.682] (**) Option "xkb_layout" "us"
[    16.207] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): connected
[    16.207] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): External TMDS
[    16.628] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): connected
[    16.628] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): External TMDS
[    16.760] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): connected
[    16.760] (--) NVIDIA(GPU-0): Eizo EV2730Q (DFP-0): External TMDS
[    16.775] (II) NVIDIA(0): <b>Setting mode "HDMI-0:1920x1920_30"</b>

Just curious (I know its a bit unrelated) but I am planning on using that exact lcd for a project. Are you able to confirm if a raspbery pi is able to successfully use the resolution of 1920x1920 from the hdmi into a dvi adapter? Thanks

Hello @rileycoyote,

As stated above the display works with a Jetson TX2 using HDMI -> DVI Adapter.

You just need to make sure you use the 30Hz refresh rate, the 60hz refresh rate is what caused the artifacts. The Jetson is likely to use the 60hz mode by default.

I think because 1920x1920 @ 60hz is within the bandwidth scope of dual link dvi. If you’re using an adapter it’s most likely single link. If you look at the specs of the monitor I think it shows that it requires dual link for 60hz. If you use display port you should be able to get 60hz