10.6.4 Update & CUDA GPU driver Following updating of OS X to 10.6.4 now asked to update CUDA dr

Following updating of OS X to 10.6.4 I get asked to update the CUDA driver

Just wondered how important this reported mismatch is.

Note in the screen grab the contradictory messages regarding update required and the software being up to date.

You can also see that I am running the latest CUDA driver.

My understanding of this is that this won’t affect how OpenCL works on OS X.

Please do advise.
SysPrefMessage.png

Got the same message after updating…

Same message here. And Octane render, the only reason why I installed CUDA, doesn’t lauch anymore. Instead it says: “No Cuda Capable Devices Found, Exiting…”. I’ve allready reported this at their forums.

I got the same warning, but the CUDA sample programs still work fine for me.

Luc

We’re working on it.

Got exactly the same message after updating to Snow Leopard 10.6.4

Kind of annoying, this pops up every time I reboot.

/Chris

yeah, I could solve that for now removing cuda pref.pane

Same here. Also noticed some window rendering problems (strange pattern under the bottom left and bottom right corners of some windows) on the first day or two. Definitely connected with the OS X update, somehow.

Based on a moderator from another forum, there is already a Release 19.5.8f03, located at http://"http//www.nvidia.com/object/geforce-macosx-19.5.8f03-driver.html%22, but the link is broken. It says that it is for:

  • Improved OpenGL performance for Geforce GTX 285 under certain conditions

  • Improved compatibility with recent Mac OS X Software Updates.

I needed to re-install Snow Leopard, and upgrade only to 10.6.3. Now I do not have the problem anymore!

Can someone confirm this, and can post the correct link?

Thanks,

Luis

Yup, it seems the graphics drivers for OSX are not working properly under 10.6.4,

For those using OpenCL it’s still possible to get GPU context,

What you need to do is just inject those simple OpenGL initialisation:

[codebox] glutInit(&argc, (char**)argv);

glutInitDisplayMode(GLUT_RGBA | GLUT_DOUBLE);

glutInitWindowSize(256, 256);

glutCreateWindow(“fake”);[/codebox]

Then, the following line:

[codebox] err = clGetDeviceIDs(platform, CL_DEVICE_TYPE_GPU, devCount, devices, NULL);[/codebox]

is not returning error, and in my case proper device is detected: GeForce GT 330M,

Approach kind of around, but at least it works,

cheers, Tomasz

I tried posting about this earlier on but the forums kept swallowing my attempted messages.

I heard that Nvidia had released an updated driver due to a major performance issue with the GTX 285 and 10.6.4. Here’s google’s cache of the page: http://webcache.googleusercontent.com/sear…&gl=us&

(No, the download link on the page doesn’t work). Looks like they pulled the update for some reason.

I got the same warning after updating…

Woo hoo! Looks like it might be back up:

http://www.nvidia.com/object/geforce-macos…f03-driver.html

Installed the new driver, but it didn’t resolve the problem.

/Chris

Did the same. Installed the new driver (19.5.8f03.dmg) for my Quadro FX 4800 Mac and I still have the same problem.

it didn’t resolve the problem.

[attachment=17545:a.tiff]

Is anyone else having more serious problems than just the pref pane message (which I also get)? I’m having problems with many GPU-accelerated apps. Magic Bullet looks (plugin for Final Cut Pro and After Effects) won’t even load - and I know it is heavily reliant on the GPU. Before the 10.6.4 update it was fine. The f03 driver did nothing for me.

EDIT… ok so I realized I had downloaded and installed the new driver before it “went away” and came back, so I thought I’d try again. I figured I should also try a few other things, so I re-installed the nvidia driver, re-installed the CUDA driver, ran Onyx and had it repair permissions, run maintenance scripts, and clear caches. I then re-installed Magic Bullet Looks and it seems to work again - not sure exactly why it got messed up or if it’s related. I’ve yet to run any benchmarks but I will try something this evening. So my update is that things seem to be working again… although I still get that alert on boot.

I have several problems even with applications that don’t use Cuda drivers, like Vue Infinite and Maya. Any official word from nVidia about a possible date for the new drivers ?

I ran into the same issue after 10.6.4 but all GPU-dependent apps work fine: Maya, CS5…
The only thing is this annoying message at boot.
Reading this thread I saw a reply from an employee at nVidia and he said they are working on it.

It’s gonna take a while I guess…

Cheers to all

L