14.7 installation directory not created

I tried to install over a 12.4 installation (full installation package, not upgrade). Outcome: See below. Then I tried to delete everything from /opt/pgi except license.dat and install again. Outcome: see below. What can I do?

contents of /opt/pgi after installation: Only the ‘2014’ folder, so no 14.7 subfolder, no compiler binaries to be found anywhere.

Sadly the installation script seems to ignore or not check errors and continues its operation, so it’s hard for me to find the cause.

Linux version:

[root@fg01 pgi]# cat /proc/version
Linux version 2.6.32-279.el6.x86_64 (> mockbuild@c6b9.bsys.dev.centos.org> ) (gcc version 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC) ) #1 SMP Fri Jun 22 12:19:21 UTC 2012

Install script output (after answering the installation questions - all of them default/yes/accept).

Installing PGI JAVA components into /opt/pgi
Installing PGI CUDA components into /opt/pgi
Do you wish to install MPICH? (y/n) y
Installing PGI MPICH components into /opt/pgi
/home/michel/libbuild/pgi/install_mpich: line 75: /opt/pgi/linux86-64/14.7/bin/localrc: No such file or directory

See the files [,.sh]
for examples of how to set your environment to run and debug MPI programs.

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_COLLATE = “en_US.UTF-8”,
LC_CTYPE = “UTF-8”,
LANG = “en_US”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
Done
The specified pgi install directory is invalid
/opt/pgi/linux86 and /opt/pgi/linux86-64 have no installed PGI versions
Usage: pgi.module.install
[-all | version version…]
[-pgi /opt/pgi/linux86/7.0/module]
[-install /usr/local/Modules/modulefiles]
ERROR: /opt/pgi/linux86-64/14.7/bin/pgi_license_tool: file not found.

Do you want the files in the install directory to be read-only? (y/n) n


Installation complete.


If you purchased a software subscription, please note that the support
services to you are limited to the terms described in the file
/opt/pgi/linux86-64/14.7/doc/SUBSCRIPTION_SERVICE.

A copy of this file can also be found on the PGI website, at
http://www.pgroup.com/support/SUBSCRIPTION_SERVICE> .


Please check the FAQ at > http://www.pgroup.com/support/faq.htm > for a current
listing of customer support concerns, including installation, use of PGI
software, and other questions or problems.

This product uses the STLport Standard Template Library for ANSI C++. The
STLport license can be found at > http://www.stlport.com/doc/license.html> .

/dev/null permission:

[root@fg01 pgi]# ls -l /dev/null
crw-rw-rw-. 1 root root 1, 3 Jul 24 21:53 /dev/null

The lack of a localrc file in $PGI/linux86-64/12.4/bin is usually due to one of two reasons.

  1. you failed to install gcc on the platform. so localrc could not be created
    to log where gcc, its headers and libs, are.

  2. The way the pgi install script in 12.4 looked for the gcc version failed
    to work correctly with with the gcc version (too new?) and so localrc was
    not created.

Convince yourself that you have a working gcc compiler installed and in
your path.

Thanks for your help. I’m appending the output of “gcc --version”. Do you have an idea on how to proceed?

[michel@fg01 pgi]$ gcc --version
gcc (GCC) 4.4.6 20120305 (Red Hat 4.4.6-4)
Copyright © 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

I have the same problem, but my old version is 13.7

I had 13.7 successfully installed, /opt/pgi/linux86-64/13.7 and /opt/pgi/linux86-64/2013 both exist.

When I tried to install 14.7, I got several errors meaning that /opt/pgi/linux86-64/14.7 does not exit, and indeed it does not, and the script did not create it. Creating the directory manually does not help, the files inside do not exist either.

The 13.7 tarfile contained an INSTALL.txt and a .parts directory, the 14.7 one (pgilinux-2014-147-x86_64.tar.gz) contains none of them. It seems the .parts directory should contain a list of the files to install, that would explain why nothing is installed.

And the problem persists with 15.3.

Ignazio,

I apologize if I am asking very basic questions. Just ruling
out things. Try this with 15.3, which has the latest makelocalrc
and if gcc has moved things around again, it has the best chance of
finding them.

\

  1. you downloaded the pgi 64-bit Linux package into a scratch area.
    You are not installing the compilers in the same area as the untar’d
    download.

  2. You untar’d the download into some scratch area, and you did not
    copy the ‘area’ to another directory. ‘cp’ leaves out files beginning
    with a period, and makes the installation fail.

  3. Before you install the compilers, you made sure that gcc is in your
    $PATH, and is capable of build a simple hello.c program

#include <stdio.h>
int main(){printf(“Hello!\n”);}


% gcc -v -Wl,-t hello.c -o hello

look at the verbose output, and determine where gcc include files, lib files,
and crt*.o files come from. The localrc file PGI creates should be able to
find these. If you have multiple versions of gcc, you may need to create
the localrc file more carefully.

The MPI installation tries to install in the $PGI/linux86-64/2014 or 2015
directory, in case there are problems with that.

You may have better luck contacting TRS trs@pgroup.com.

regards,
dave

dave

My apologies, it looks like I made some mistake. I’m generally aware of the problems using “cp *” (missed dotted files), but I redid all the steps and now the “.parts” directory shows up, so I must have made a mistake before. In sum: it works. Thanks