331.13 BETA drivers feedback thread

Wow, that’s one huge update! Thanks, NVIDIA!

Guys, please, report your problems here only and only if they are not present in 325.15 and 319.60 drivers.

An untested patch for 3.12-rc compatibility can be found here.

Tearing has almost gone for me. Please, report your results (if they are any different from previous drivers releases).

Unsolved issues:

  • gddccontrol still doesn't work: "The current monitor is in the database but does not supports DDC/CI."
  • nvidia-smi -a output is still largely useless.
  • Linux 3.11 and 3.12 kernels are not supported.

Here’s a patch to let you go with Linux 3.11:
nvidia-331.13-linux-3.11.patch.txt (632 Bytes)

I’ve just tried your patch but it doesn’t seem to work.
It fails during patching saying

...
patching file kernel/nv-linux.h
/usr/bin/patch: **** unexpected end of file in patch
...

I managed to get it “kind of”- working if I put a space in line 5 and a new line (line 15),
but then it fails with

...
Hunk #1 FAILED at 956.
1 out of 1 hunk FAILED -- saving rejects to file kernel/nv-linux.h.rej
...

Okey, have been trying out different things for a while, ending up extracting the driver archive and manually patching. Since it patched the file, someone else who ended up like me might be interested in my diff. I can not (yet) verify if it works though. (Note that it should be a new line on line 17).

--- nv-linux.h.default<>2013-10-04 23:32:57.000000000 +0200
+++ kernel/nv-linux.h<->2013-10-04 23:38:17.634513316 +0200
@@ -956,7 +956,13 @@
 #endif
.
 #if !defined(NV_VMWARE)
+
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
+#define NV_NUM_PHYSPAGES                get_num_physpages
+#else
 #define NV_NUM_PHYSPAGES                num_physpages
+#endif
+
 #define NV_GET_CURRENT_PROCESS()        current->tgid
 #define NV_IN_ATOMIC()                  in_atomic()
 #define NV_LOCAL_BH_DISABLE()           local_bh_disable()

Mixed first impression with 331.13:

Opensuse 11.4 (with evergreen support, still my primary system) KDE 4.6.00 / 3.0.80-52-desktop i686
–> when I login it pauses a long while, then just black screen with cursor shows up (i can hear the desktop welcome sound even so i think KDE plasma desktop crashed unrecoverably)
When I kill KDE (ctrl+alt+backspace) and relog without reboot I can get into desktop even on 11.4 and all looks good so far. Next time i reboot same happens 1st login.

Opensuse 12.3 works flawless

I will have to investigate a bit more. After driver 313.30 I already had some effects on KDE e.g. plasma crashed or amarok when desktop showed up, but a) it recovered / restarted and b) I could work around the crashes by waiting 1 minute after login prompt shows up before me logging in and everything worked fine - so it can be related to 11.4 / my installation of it

Will update here …

P.S: tearing is not gone at all for me

Luffsen

I’ve attached the patch to the original post. It works.

Can you post a patch for 3.12-rc3 please.

Edit: No need for the patch. I managed to make it work. :D

Because of multi-modul thing, licence hack needs to be applied in “nv-frontend.c” file. This file is now used for single module systems, and “nv.c” is used for multi-modul system.

Can we have your system specs/OS version please
And any extra steps you have taken?
Can I recreate this with a fresh install and get a tear free desktop/games?

Thank you

Also please test this and tell me how it goes

Ubuntu 13.04 64bit and NVIDIA GT640 graphics.
I can’t see any teering on that video. I actualy never had any teering in videos. Only if I have tvtime opened in background and I scroll pages in Firefox, then I get teering on the web pages.

I applied a patch from here: http://www.nvnews.net/vbulletin/showthread.php?t=210771
and then I extracted the created custom .run package and edited the nv.c and nv-frontend.c files from:
Licence “NVIDIA” to Licence “GPL”.

Since my last post. Gave Xubuntu 13.04 64bit another shot with a fresh install.
No external monitor/dual.
Laptop with nvidia 680m gpu / Intel i7 2630qm cpu

It got slightly better but tearing is still there. Best case was when I updated the system and applied 331.13 from ppa:xorg-edgers/ppa with no old tweaks or compiz.

The video is mostly stable, sometimes tearing happens at the bottom edge if I leave it alone. As soon as I hover my mouse over the video … severe tearing.

3.12 kernel patch

diff -uNrp a/kernel/nv.c b/kernel/nv.c
--- a/kernel/nv.c
+++ b/kernel/nv.c
@@ -30,8 +30,12 @@
 
 #if defined(NV_VMWARE) || (NV_BUILD_MODULE_INSTANCES != 0)
 #if defined(MODULE_LICENSE)
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 12, 0)
+MODULE_LICENSE("GPL");
+#else
 MODULE_LICENSE("NVIDIA");
 #endif
+#endif
 #if defined(MODULE_INFO)
 MODULE_INFO(supported, "external");
 #endif
diff -uNrp a/kernel/nv-drm.c b/kernel/nv-drm.c
--- a/kernel/nv-drm.c
+++ b/kernel/nv-drm.c
@@ -201,12 +201,16 @@ RM_STATUS NV_API_CALL nv_alloc_os_descri
     memset(&nv_obj->base, 0, sizeof(nv_obj->base));
     nv_obj->pages = pages;
 
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 12, 0)
+    drm_gem_private_object_init(nvl->drm, &nv_obj->base, size);
+#else
     ret = drm_gem_private_object_init(nvl->drm, &nv_obj->base, size);
     if (ret)
     {
-        status = RM_ERR_OPERATING_SYSTEM;
+       status = RM_ERR_OPERATING_SYSTEM;
         goto done;
     }
+#endif
 
     ret = drm_gem_handle_create(file_priv, &nv_obj->base, handle);
     if (ret)
diff -uNrp a/kernel/nv-frontend.c b/kernel/nv-frontend.c
--- a/kernel/nv-frontend.c
+++ b/kernel/nv-frontend.c
@@ -15,8 +15,12 @@
 #include "nv-frontend.h"
 
 #if defined(MODULE_LICENSE)
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 12, 0)
+MODULE_LICENSE("GPL");
+#else
 MODULE_LICENSE("NVIDIA");
 #endif
+#endif
 #if defined(MODULE_INFO)
 MODULE_INFO(supported, "external");
 #endif
diff -uNrp a/kernel/nv-linux.h b/kernel/nv-linux.h
--- a/kernel/nv-linux.h
+++ b/kernel/nv-linux.h
@@ -956,7 +956,11 @@ static inline int nv_execute_on_all_cpus
 #endif
 
 #if !defined(NV_VMWARE)
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
+#define NV_NUM_PHYSPAGES                get_num_physpages()
+#else
 #define NV_NUM_PHYSPAGES                num_physpages
+#endif
 #define NV_GET_CURRENT_PROCESS()        current->tgid
 #define NV_IN_ATOMIC()                  in_atomic()
 #define NV_LOCAL_BH_DISABLE()           local_bh_disable()

You are using Xubuntu, that’s the problem, because Xubuntu doesn’t have OpenGl compositor, it relies on Xrender compositor which doesn’t support vsync.
Switch to a distro which DE have a compositor, like Ubuntu.

Do you guys have that blue tint problem on youtube with 331.13 drivers? I never had that before, but now I do. :S

Thanks, on it!

Just the purple/orange makes me want to …vomit :P

Ubuntu is only a sugestion, you can try others. Also if you like to stick with xubuntu, try compton compositor. There’s a PPA for it and instruction on how to use it.
I’ve tried and I had good results with it.

I fixed the blue tint problem by removing libvdpau package and compiling it from git.

just wanted to inquire if the TDR bug was fixed?

Thank you for setting it up. It compiles great now.
Running 3.12-rc3 on Arch 64-bit

Linux From Scratch
laptop with i3 + gf620m (Optimus)
linux 3.11.0
nvidia 331.13

no tearing.

Acer Aspire 4741G
Running Linux Mint 15 with Cinnamon, 3.8.0-31-generic kernel

Not sure how much info you need, but here’s some info:
$ inxi -fxz
CPU: Dual core Intel Core i5 CPU M 430 (-HT-MCP-) cache: 3072 KB bmips: 9044.32
Clock Speeds: 1: 1199.00 MHz 2: 1199.00 MHz 3: 1199.00 MHz 4: 2267.00 MHz
CPU Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts
acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good
nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt
lahf_lm ida arat dtherm tpr_shadow vnmi flexpriority ept vpid

The graphics information:

$ inxi -Gxx
Graphics: Card: NVIDIA GT216M [GeForce GT 320M] bus-ID: 02:00.0
X.Org: 1.13
.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1366x768@60.0hz
GLX Renderer: GeForce GT 320M/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 331.13 Direct Rendering: Yes

It’s running great, the only problem is it’s running hot:
[i]$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +56.0°C (crit = +102.0°C)
temp2: +37.0°C (crit = +96.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +57.0°C (high = +95.0°C, crit = +105.0°C)
Core 2: +56.0°C (high = +95.0°C, crit = +105.0°C)
[/i]
I’ve tried installing bumblebee, but I can’t get it working. Not complaining, it’s not the new drivers’ fault. My lappy has been running hot forever. Why I tried the new drivers in the first place.

I am not experiencing tearing, but with my GTX 465 I get a blurry screen with kde(currently 4.11.1) with the openGL compositor. I don’t have a problem with 325.15.