387.34 almost works...libgl.so problem then more downgrade to Fedora 26 with no luck.

Close Print the Transcript
Status: Disconnected
Prakash - P: Hi, my name is Prakash - P. How may I help you?
You: Hi I was hoping you could help me get a working driver that I don’t have to debug or change kernel versions for fedora 27x86_64
You: I have spent the entire night rebuilding f26 to your drivers specs to no avail
Prakash - P: Surely, I will do my best to help you.
You: Nothing works not 301 not 340 not 387 nothing between thx
Prakash - P: May I know model number of your graphics card?
You: Geforce 765m
Prakash - P: May I know your email ID?
You: I7 4th gen MSI ge70 2oe
You: Gm2500main@gmail.com
File attachment upload has started.
The file IMG_20171213_081223.jpg (5702.7KB) was received.
You: Kernel-4.12.9-300.fc26.x86_64
You: Would love to use kernel-4.14.3-300.fc27.x86_64
Prakash - P: Let me know your computer operating system and its version.
You: Linux 64 bit fedora is distro release 27
You: I’m using proprietary driver packs from nvidia website
Prakash - P: Download and install driver,

Installation instructions: Once you have downloaded the driver, change to the directory containing the driver package and install the driver by running, as root, sh ./NVIDIA-Linux-x86_64-387.34.run

One of the last installation steps will offer to update your X configuration file. Either accept that offer, edit your X configuration file manually so that the NVIDIA X driver will be used, or run nvidia-xconfig

Note that the list of supported GPU products is provided to indicate which GPUs are supported by a particular driver version. Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available. Hardware designs will vary from manufacturer to manufacturer, so please consult with a system’s manufacturer to determine whether that particular system is compatible.
You: Debug is turned off of the kernels…387.34 almost works
Prakash - P: Sure
You: I know that it is
You: The nouveau (Linux driver works fine) I need the proprietary driver to make use of GPU for steam and media services
Prakash - P: I am sorry unfortunately we don’t support Linux platform, there is a separate team working on it, I will share you the link and please post your query there and an engineer will be assigned to you and have it resolved for you.
You: 387.34 loads operating system and seems to function but breaks glx
You: Thanks but if you don’t “support it” why do you make drivers for it? Isn’t the fact that you make drivers mean you support it?
You: Official employee from nvidia will contact me there?
Prakash - P: We have dedicate team who work on graphics card issues with linux platform, so I would suggest you to post your query at https://devtalk.nvidia.com/default/board/98/linux/
You: OK thank you have a good day
Prakash - P: you too!!
You have disconnected.
Powered By Oracle

Since it’s a laptop, read this:
If that doesn’t help, do this:

I’ve got the bug report and will be posting it shortly. I had already read up before posting just wanted to get it up so I could start the wait for an “official nvidia engineer.”

I wouldn’t hold my breath since your issue is just the ‘missing config, no clue what to do’ issue that has been answered a 1000 times before. The devs step in when a possible driver bug is reported or they’re late for work so they have to answer 5 posts (kidding).

Thanks for the advice haha I know. I think the general config minimalization of the issue isn’t quite a fair diagnosis. I’ve tried nearly every “certified driver” from them and none work. I have a xorg.conf file generated by nvidia xconfig that matches what others have working. Its ludacris that Nvidia is allegeding they don’t support Linux as they clearly are trying to but crowd source most of the effort. I’m a big fan but this has been kind of disappointing so far.

We won’t be able to help you without an nvidia-bug-report.log.gz file and a detailed description of the problem. Please see https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

So I have two logs here one is from Fedora 26 Kernel 4.12.9 (original kernel 340.104 driver was compiled on) with 1 in the filename. Second is from Fedora 27 Kernel 4.14.3 latest stable and driver version 387.34 with 2 in filename.

340.104 fails to yield a desktop environment and just hangs at loading GDM prompt

387.34 yields GDM login screen and post login now freezes with TTY only available starting on TTY3. Before I had this new problem, I was getting errors for libGL.so and failure of glxinfo unable to process requests. Farthest I was able to get was some RGB failure message followed by one that also listed something with symbols…I’ve been coding all night and now I’m busy with work. I’ll try to document everything better in any of our future talks.
nvidia-bug-report1.log.gz (198 KB)
nvidia-bug-report2.log.gz (219 KB)

Thanks for the bug report log. I looked at the second one.

It looks like your X server is not configured to use Prime, and you set it (using Option “AllowEmptyInitialConfiguration”) to start even though the GPU doesn’t have any connected display devices. So it’s expected that you won’t be able to see anything after the X server starts.

You’ll need to follow the instructions on setting up a Prime configuration. The ones generix linked to look like a good start.

Alright…I’ll try these settings and or mark correct if successful. I seriously have my doubts. What’s with Nvidia and the silly names for configurations? Also, if this is needed in general for every setup, why isn’t it taken care of by the “Nvidia certified driver?” It seems like there should be less of these drivers available on the site. I.e.: one for truly legacy devices another for devices getting to be close to legacy and new devices…but there are at least 10 versions there…

Doing better no freeze but after login just sent back to login screen
nvidia-bug-report.log.gz (89.4 KB)

Which steps did you take?
Pleas run nvidia-bug-report.sh again and attach.

There’s a typo in your xorg.conf, “Virtua” should read “Virtual”

Changed it (added the l) At this point I’m going to do a full wipe and reinstall. It seems to be a permission issue but setting selinux permissive has no effect. I will see if I reproduce and get back with an updated debug log. Thank you for all your help.

Some explanations what is going on with your laptop so this might be easier for you:
Your laptop is an Optimus system, which means that all your displays are connected to the intel gpu. The nvidia gpu has no outputs. In order to use the nvidia gpu, some prerequisites have to be met

  • the intel gpu has to be working
  • the nvida drivers have to be installed, nvidia glx has to be used
  • the xorg.conf has to configure both gpus
  • the framebuffer of the nvidia gpu has to be rerouted to the intel gpu using xrandr commands
    Basically when using gnome, it is sufficient for your system to just c/p the xorg.conf and the two optimus.desktop files from my link.
    If something fails, always look first at the /var/log/Xorg.0.log, e.g. when you had the typo, X refused to start because of that and told so in the log. GDM then fell back to a wayland session for the login but was unable to start an X user session.
    Since RHEL/Fedora does not support the nvidia binary driver you have to do everything by hand as it is missing the necessary infrastructure. If you want to have this autoconfigured, you have to use something ubuntu-based and use the provided packages and not the .run installler.