346.16 Beta X Server Error: Failed to Initialize GLX Extension (Compatible Nvidia X Driver Not Found

Environment: MSI GE60 - GeForce GTX 765 M - Ubuntu 14.10 - Linux 3.16.0-24

I installed last Nvidia driver after having

  • purged xserver-xorg-video-nouveau and its dependency
  • blacklisted Nouveau driver by inserting /etc/modprobe.d/blacklist-nouveau.conf:
    blacklist nouveau
    blacklist lbm-nouveau
    options nouveau modeset=0
    alias nouveau off
    alias lbm-nouveau off
  • updated 'initramfs": update-initramfs -u
  • rebooted
  • entered a non graphical environment at login with ctrl-alt-F1
  • stopped lightdm (display manager) with /etc/init.d/lightdm stop
  • launched sh ./NVIDIA-Linux-x86_64-346.16.run
  • verified that the Nvidia driver was loaded with lspci:

root@MSI-GE60-Ubuntu-14:-# lspci -vnn | grep NVidia -A 17
.01:00.0 3D, controller [0302]: NVIDIA Corporation GK106M [GeForce GTX 765M] [10de:11e2] (rev a1)
Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:1001 ]
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at f6000000 (32-bit , non-prefetchable)
Memory at c0000000 (64-bit , prefetchable)
Memory at d0000000 (64-bit, prefetchable)
I/0 ports at e000
Expansion ROM at f7000000 [disabled]
Capabilities: [60] Powe Management version,3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=1 REv=1 Len=24 <?>
Capabilities: [900] #19
Kernel driver in use: nvidia

  • and with lsmod:
    root@MSI-GE60-Ubuntu-14:-# lsmod | grep nvidia
    nvidia 8422497 0
    drm 310919 5 i915,drm_kms_helper,nvidia

The error described in this thread title happens before I launch nvidia-xconfig or after.

I have provided additional traces here:

What could be done to solve or work around this issue?

your laptop has both nvidia and intel gpu’s, you have to perform a special install i believe. here’s a post about it: http://askubuntu.com/questions/332026/trying-to-install-proprietory-nvidia-graphics-drivers

Thanks, but the link you provide deals with the installation of Nvidia drivers offered by the official repositories. They are outdated. I already tried them once and they worked OK, with some flaws.
What I’m trying to achieve here is different: installing the last driver provided by Nvidia which is a big enhancement: http://news.softpedia.com/news/NVIDIA-Launches-Massive-Linux-Driver-Update-464935.shtml

im aware of what you’re trying to do, i don’t know if nvidia’s driver package comes with the switcher, so i believe you need to install nvidia-prime. Have a read: http://www.phoronix.com/scan.php?page=news_item&px=MTU0MDI

nvidia-prime should work with any version of the nvidia binary.

I’ve followed your advice and installed “nvidia-prime” 0.6.7 (last official release).

I didn’t work because “Sorry but your hardware configuration is not supported”.

I’ve discovered another error message in the Xorg.0.log:
(EE) No devices detected.”

There might be a line missing int /etc/X11/xorg.conf:

Section "Device"
...
    <b>BusID	   "PCI:1:0:0</b>"
EndSection

I’m going to try this and let you know about the outcome.

Here are all the steps I’ve used to workaround that issue:

  • xserver-xorg-dev installation
  • all the steps explained in my first post
  • after nvidia-xconfig, xorg.conf modification (after nvidia-xconfig --query-gpu-info):
...
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    <b><u>BoardName      "GeForce GTX 765M"</u></b>
    <b><u>BusID          "PCI:1:0:0"</u></b>
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "<b><u>nvidia0</u></b>"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        <b><u>Modes       "1920x1080" "1600x1200" "1024x768"</u></b>
    EndSubSection
EndSection
  • lightdm reinstallation with “apt-get install -reinstall lightdm”
  • reboot

A black screen appears during startup and after login (which I pass blindly after the drums).
However, the Xorg.0.log shows no more EE errors, except that the Nvidia driver does not detect any device: cat /var/log/Xorg.0.log | grep -i nvidia -C 3

[    23.922] (--) PCI: (0:1:0:0) 10de:11e2:1462:10e0 rev 161, Mem @ 0xf6000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    23.923] (II) LoadModule: "glx"
[    24.037] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    25.592] (II) Module glx: vendor="NVIDIA Corporation"
[    25.592] 	compiled for 4.0.2, module version = 1.0.0
[    25.592] 	Module class: X.Org Server Extension
[    25.593] (II) NVIDIA GLX Module  346.16  Fri Nov  7 16:24:03 PST 2014
[    25.598] (II) LoadModule: "nvidia"
[    25.598] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    25.679] (II) Module nvidia: vendor="NVIDIA Corporation"
[    25.679] 	compiled for 4.0.2, module version = 1.0.0
[    25.679] 	Module class: X.Org Video Driver
[    25.682] (II) NVIDIA dlloader X Driver  346.16  Fri Nov  7 15:59:29 PST 2014
[    25.682] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    25.682] (++) using VT number 7

[    25.689] (II) Loading sub module "fb"
--
[    25.732] (II) Loading sub module "ramdac"
[    25.732] (II) LoadModule: "ramdac"
[    25.732] (II) Module "ramdac" already built-in
[    25.733] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    25.733] (==) NVIDIA(0): RGB weight 888
[    25.733] (==) NVIDIA(0): Default visual is TrueColor
[    25.733] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    25.750] (**) NVIDIA(0): Enabling 2D acceleration
[    26.334] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[    26.335] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 765M (GK106) at PCI:1:0:0 (GPU-0)
[    26.335] (--) NVIDIA(0): Memory: 2097152 kBytes
[    26.335] (--) NVIDIA(0): VideoBIOS: 80.06.5d.00.09
[    26.335] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    26.335] (--) NVIDIA(0): <b><u>Valid display device(s) on GeForce GTX 765M at PCI:1:0:0</u></b>
[    26.335] (--) NVIDIA(0):     <b><u>none</u></b>
[    26.335] (II) NVIDIA(0): Validated MetaModes:
[    26.335] (II) NVIDIA(0):     "NULL"
[    26.335] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[    26.345] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[    26.345] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[    26.345] (--) Depth 24 pixmap format is 32 bpp
[    26.345] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[    26.345] (II) NVIDIA:     access.
[    26.351] (II) NVIDIA(0): Setting mode "NULL"
[    26.405] (II) NVIDIA(0): Built-in logo is bigger than the screen.
[    26.408] (==) NVIDIA(0): Disabling shared memory pixmaps
[    26.408] (==) NVIDIA(0): Backing store enabled
[    26.408] (==) NVIDIA(0): Silken mouse enabled
[    26.408] (**) NVIDIA(0): DPMS enabled
[    26.408] (II) Loading sub module "dri2"
[    26.409] (II) LoadModule: "dri2"
[    26.409] (II) Module "dri2" already built-in
[    26.409] (II) NVIDIA(0): [DRI2] Setup complete
[    26.409] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    26.409] (--) RandR disabled
[    26.411] (II) SELinux: Disabled on system
[    26.412] (II) Initializing extension GLX

Now, the question that remains is:
why Nvidia most advanced driver is not able to detect the display whereas the open source nouveau driver can?

depending on the display it’s connected to, it may just not be getting any EDID info. look into extracting edid info from the display you’re connected to so that you can tell xorg.conf which EDID file it should read from. there’s google that can help you with this. :)

That’s my only suggestion at this point. have you also checked out lightdm log files also? can you ssh into the machine because you know it’s booting into ubuntu since you hear the startup sounds. you could try recovery mode just so you can use a terminal to install ssh? you could also use recovery mode to create the edid file.

actionmystique, first reproduce the issue and provide nvidia bug report by running nvidia-bug-report.sh script as root user. It will generate log file in your current directory. Is any earlier nvidia driver worked on your notebook ? Are you using only nvidia gpu with nvidia driver? OR intel+nvidia gpu with help of nvidia-prime feature?

Thanks @ubuntuaddicted and @sandipt for your answers.

I will look into this next week-end.

@sandipt: Before I reproduce the issue, some answers to your questions:

  • some earlier nvidia driver worked on this system (from the official ubuntu repositories), but there were some bugs
  • my hardware has an Intel i7 4700 MQ chipset; so it has Intel graphical capabilities - Intel® HD Graphics 4600, but I'd like to use only Nvidia GTX 765M GPU
  • as written above in one of my post, the nvidia-prime package available on the official ubuntu repositories is not compatible with my system

@sandipt: I’m providing 2 reports after the driver installation, reboot and black screen:

Thanks for looking into this.

As you can see in both logs, there are the following errors:

nvidia-settings -q all:

gdk_mir_display_open
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
No protocol specified

ERROR: Unable to load info from any available system

xrandr --verbose:

No protocol specified
Can't open display :0

Did you ever figure out a solution?