nvidia-settings ERROR: Unable to load info from any available system

Hello,

I can’t run nvidia settings and because of it I can’t switch from Intel graphic card to Nvidia one.

When I open nvidia settings by clicking on icon it doesn’t open at all. Using terminal I get a message:

ERROR: Unable to load info from any available syste

How can I fix it?

I use Ubuntu 16.04.

$ uname -a
Linux joanna-Inspiron-7559 4.13.0-39-generic #44~16.04.1-Ubuntu SMP Thu Apr 5 16:43:10 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

My Nvidia graphic card is GeForce GTX 960M.

$ lspci -nnk | grep '\[03'
00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:191b] (rev 06)
02:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 960M] [10de:139b] (rev ff)

I also get this info which can be an issue.

$ nvidia-smi
NVIDIA-SMI couldn't find libnvidia-ml.so library in your system. Please make sure that the NVIDIA Display Driver is properly installed and present in your system.
Please also try adding directory that contains libnvidia-ml.so to your system PATH.

I would really appreciate your help.

nvidia-bug-report.log.gz (75.8 KB)

Does
sudo prime-select nvidia
work?
Otherwise, please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

hi,
I am facing a similar problem, after the latest automatic updates from ubuntu 16.04,

sudo prime-select nvidia

works fine, but still not able to open the nvidia system settings (gui/terminal)

sudo prime-select nvidia

works for me also.

I’ve added nvidia-bug-report to my first post.

I’ve also found that after

sudo prime-select nvidia

command

glxinfo|egrep "OpenGL vendor|OpenGL renderer"

gives an error:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  35
  Current serial number in output stream:  36

After switching to Intel (sudo prime-select intel) it gives normal information:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)

Hello,
I have exactly the same problem with Ubuntu 14.04.5 LTS and the Nvidia 390/396 driver, on 3 computers:
One HP Omen 17" and two HP Omen 15".

Three laptops with an Intel Graphics (7th gen) and a Nvidia GTX 1050.

Kernel version: 4.4

Before the Nvidia 390 version I didn’t see this problem.

On the Nvidia GPU: No problem.
On the Intel GPU: Unable to open nvidia-settings. Unable to run nvidia-smi.

With:

export LD_LIBRARY_PATH=/usr/lib/nvidia-396/

I can run nvidia-smi, but nvidia-settings print:

ERROR: Unable to load info from any available system.

But,

prime-select nvidia

works to go back on the nvidia-gpu.

I have the same problem on Mint 18.3. However, is it the ubuntu packaging at fault? Does native nvidia-settings do anything useful when the nvidia card is powered off and the driver is not loaded?

I never had any problem like this with the ubuntu packages, and in addition, I use the ppa:graphics-drivers/ppa to keep my drivers up to date, and except with really recent releases (390 - 396) I never had any problem like that.

In a normal way, when the nvidia driver is not loaded, nvidia-settings show the prime profiles, and make us able to switch between intel and nvidia GPUs.

And, a package is preferable to keep the drivers up to date, because without this, you need to re-install manually your driver from a tty at each minor kernel update, and it’s not really convenient because you need to kill the X server, and use the tty because the nvidia-installer cannot be launched when the X server is running. (This is stupid and should be changed in future releases because it’s awful…, the installer should use dkms like others installers/packages…and should run from a X session even if a X restart is needed. Even AMD do this with his ugly drivers for Linux…)

The reason the .run installer requires you to stop X is because the first thing it does after building the new kernel module is to test-load it. It can’t do that if the old kernel module is still in use by the X server.

The reason for the test-load step is that there have been a huge number of cases in the past where the module will build fine, but won’t load for any number of reasons. For example, see the recent cases where the module builds but fails to load because the kernel build system doesn’t stamp the module with a new ‘retpoline’ tag. If the .run package just put the module into dkms and then continued the installation assuming everything was fine, this mismatch would result in a non-functional X server and the infamous “login loop” on the next reboot.

When Linux distributions package the driver, they can make stronger guarantees about whether the module will work after an update.

Ok this is a good reason.
I just think (personnaly) that is a little bit difficult to install the latest driver for the lambda end-user. (In comparaison with the way to install the Windows Nvidia driver), but I understand this choice.

This prime switch feature is an Ubuntu enhancement to the nvidia code. That’s why I think it is an ubuntu problem: it is an ubuntu feature which is broken. So I don’t think you’ll make much progress discussing it here. If you remove the ubuntu nvidia-settings module and install the nvidia one from the nvidia installer, you will not see the card switching section.

I suggest you file a bug against the ubuntu package.

Just be sure not to have any

/etc/X11/xorg.conf*

files.
Run this:

sudo rm -v /etc/X11/xorg.conf*

I had this problem recently on Ubuntu 18.04, and while being on intel, I ran

nvidia-xconfig

then

sudo prime-select nvidia

and rebooted; but gdm would no longer load. So I booted on an USB live image and noticed two /etc/X11/xorg.conf* files which I removed (one empty and the nvidia-xconfig file backed up). Then rebooted again and I could log in having nvidia driver perfectly working.

Maybe this will help.

Hello,

I tried the commands and at first everything ok. After rebooting, it did not work. After deleting xorg.conf again and rebooting, I was able to access again.

Is there a problem with nvidia-driver-396?

Hi,

There are some new things with nvidia-driver-390+. More exactly those drivers are made for future versions of the display server that have not landed yet in Ubuntu. This is why they get the name “nvidia-driver-*” to tell them apart and also why you actually need to reboot you computer. They’ve been made to work with what we have at this point.

Now, I’m not sure what distro you’re using. I’am on Ubuntu 18.04 and it is a fresh install. Whatever you’ve got there, whether you upgraded your distro, or you are on 16.04, you must have a reminiscence of the old drivers. When you’re switching from intel to nvidia or the other way around the new driver mechanism runs

update-initramfs

and

update-grub

It might be that when this is done, there’s also going on the creation of the apropiate xorg.conf, which is like the older drivers behaved.

As a workaround you can try to create a Post Session (post logout) script that removes the file.

Thanks @cyberalex4life for the help!!

I removed the driver completely and any traces of it and reinstalled again. I rebooted the machine and performed the commands described by you. I rebooted again and even then nvidia-settings does not work.

Returns the error:

# nvidia-settings 

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

Any other idea?

I also have this error on my system, and they usually say it’s from write permissions in BIOS. However:

sudo prime-select nvidia

and

sudo prime-select intel

work perfectly, and nvidia-settings also works after switching to nvidia.

I’ve build an indicator with Argos (https://extensions.gnome.org/extension/1176/argos/) extension here: https://github.com/cyberalex4life/argos-indicator-nvidia-prime. which I personally use all the time. Feel free to modify it as you wish.

But first try switching from command line with ‘prime-select’.

I have the same problem now on Ubuntu 18.04 with latest nvidia driver on a Intel/Nvidia hybrid system.
Displayed is always “using x.org x server – nouveau display driver”, although I’ve installed Nvidia 410 and switch around with prime-select.

Try adding

nouveau.modeset=0 rd.driver.blacklist=nouveau

to

GRUB_CMDLINE_LINUX_DEFAULT=

in

/etc/default/grub

I’ve encountered this over many linux distro’s. You need to be root to edit this file. After that run

sudo update-grub

then reboot.
If this doesn’t work, since you’re using the latest drivers that need reboot, try running

sudo update-initramfs -u -k all

after switching with prime-select, then reboot again.
Come back again on this thread if editing ‘grub’ file doesn’t work.

I’m facing similar problem but here nvidia is loaded fine. I would like to know what exactly is nvidia-settings loogink for (or what is really missing) when it returns

ERROR: unable to load info from any available system

Hi, i’m facing up to the same problem but my nvidia driver module is loaded successfully. However, the

nvidia-settings

and

prime-select

command crashed:

nvidia-settings 

ERROR: Unable to load info from any available system
sudo prime-select nvidia
Info: the current GL alternatives in use are: ['mesa', None]
Info: the current EGL alternatives in use are: ['mesa-egl', None]
Error: the installed packages do not support PRIME
Error: nvidia mode can't be enabled

Is there anyone who can help me? i’ll really appreciate your help!
/home/fc/nvidia-bug-report.log.gz

nvidia-bug-report.log.gz (90 KB)

  • Don’t use the .run installers, use --uninstall to uninstall them
  • purge anthing nvidia/cuda
  • add the ubuntu graphics ppa https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
  • install the driver from that (sudo apt install nvidia-driver-415)
  • download the cuda .deb
  • add the repo to your system (first three steps from install instructions on download page)
  • don’t install cuda
  • instead, run sudo apt install cuda-toolkit-10-0

If you have further questions/problems, please open a new thread.