NVIDIA driver is not loaded. Ubuntu 18.10

I have problems with Nvidia drivers, on ubuntu 18.10.

Linux ****-dell 4.18.0-15-generic #16-Ubuntu SMP Thu Feb 7 10:56:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

My notebook is using both intel integrated and external GPU. (1060 max Q).

I have dual boot with windows and secure boot disabled. Some time ago I installed nvidia drivers and it worked normally. nvidia-smi was working.

This week I noticed that nvidia drivers weren’t loaded, so I reinstalled them multiple times, with multiple different version: (390.87, 410.78, 415.13). I have tried installing from both command line and “Software & update” app.

Right now I have driver version 390.87.
Things I have tried so far:

  • Clean installation of multiple driver versions. Never from run file.
  • Blacklisting nouveau in blacklist-nvidia-nouveau.conf with: blacklist nouveau; options nouveau modeset=0
  • Setting WaylandEnable=false
lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev a1) (prog-if 00 [VGA controller])

nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

nvidia-settings 
ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

nvidia-bug-report.log.gz (65.6 KB)

Please make sure the package nvidia-prime is installed:

sudo apt install nvidia-prime

Afterwards, run

sudo prime-select nvidia

Please check if the file

/lib/modprobe.d/blacklist-nvidia.conf

exists, delete it, then run

sudo update-initramfs -u

and reboot.

1 Like

Thanks for reply.

nvidia-prime was installed and nvidia profile selected, but there was blacklist-nvidia.conf in

/etc/modprobe.d/blacklist-nvidia.conf

I feel stupid missing that file.

Thanks very much generix.

Even dual monitor setup is working, which wasn’t at 18.04.

1 Like

I installed nvidia-prime and it says nvidia profile is already selected.
I am still experiencing this issue despite not having “/etc/modprobe.d/blacklist-nvidia.conf” in my system.

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

1 Like

I am experiencing a similar problem trying to get the NVIDIA driver running on my SurfaceBook-2 running Ubuntu 18.04.3 LTS in a dual-boot dual-monitor (via Surface Dock) with Windows and secure boot disabled.

Settings->Details shows Graphics: Intel UHD Graphics 620 (Kabylake GT2)
lshw -c display shows -display … product: UHD Graphics 620 …-display UNCLAIMED … product: GP106M [GeForce GTX 1060 Mobile]
apt install nvidia-driver-430 yields …nvidia-driver-430 is already the newest version (430.26-0ubuntu0.18.04.2)…
prime-select query prints “nvidia”
There is no /lib/modprobe.d/blacklist-nvidia.conf in my system (nor in /etc/…)
There is no /etc/X11/xorg.conf.d folder
lspci -v shows Intel Corp UHD Graphics 620 for VGA compatible controller but also -2:00.0 3D controller: NVIDIA Corporation GP106M …Kernel moduls: nvidiafb, nouveau, nvidia_drm, nvidia

I have rebooted several times with no joy.

Any ideas?
nvidia-bug-report.log.gz (57.2 KB)

[    0.000000] secureboot: Secure boot enabled

Secure boot is still enabled.

Thanks for spotting that. Not sure how that happened, but I think it is corrected now. I still cannot get the NVIDIA GPU working though. (I would like to run the GPU enabled TensorFlow and GPU enabled OpenCV.) I have rolled back the driver to 390 and back to 430 (rebooting in the process). I cycled between Intel and Nvidia using prime-select with no success. New bug-report attached.

nvidia-bug-report.log.gz (1.07 MB)

The driver is loading now but unfortunately, no xorg logs are included. Please run
sudo journalctl -b0 _COMM=gdm-x-session --no-pager >journal.txt
and attach the output file.

It says “-- No entries --”
journal.txt (102 Bytes)

Looks like you’re running a wayland session on the igpu, then. Please try to disable it:
https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen
and post the output of
xrandr --verbose
when run from desktop.

That worked! Many thanks. Attaching xrandr output for completeness.
xrandr.log (2.42 KB)

i have same issue, i made same things but i did not resolve it. anyone help me?
nvidia-bug-report.log.gz (127 KB)

emreerinc432, you have secure boot enabled so the driver doesn’t load. Please disable secure boot in bios.

guess, problem because of this. after disabled secure boot ubuntu 19.10 didn’t boot but i reinstall 18.04 and problem was fixed. thank you so much

Hello,

I’m experiencing basically the same issues as everyone in this post, even after following all the suggestions. I’m currently running the 430 drivers for an MX230.

Things checked:

  • secure boot is disabled
  • no blacklist-nvidia.conf file exists
  • no multiple versions of drivers installed

I’m also attaching the nvidia-bug-report.log.gz.

Many thanks

nvidia-bug-report.log.gz (1.09 MB)

simpapadem, your intel cpu is too new for the running kernel so the igpu doesn’t work. Please upgrade to kernel 5.3 or use ubuntu 19.10.
The nvidia driver seems to be blacklisted as well but that’s a secondary problem.

Hi,

first of all thanks for the swift reply!

I have no real concern in using the igpu, I would much rather be able to use the separate GPU included (NVIDIA GeForce MX230). The igpu seems to be working since it is the only one currently recognized by the system. On system -> details it shows llvmpipe (LLVM 8.0, 256 bits) in the graphics row. From what I’ve read online this hints that the igpu is used.

Also, regarding the blacklist, to the best of my knowledge I only have the blacklist-nvidia-nouveau.conf file in my system.

I’m trying to avoid having to upgrade to 19.10 since they are fairly new and probably riddled with bugs. Is there a way to avoid this? Even if the igpu is not being used.

Thanks

Edit: I’m mostly interested in being able to connect the laptop to a secondary screen, which seems impossible without the GPU recognition.

This is an Optimus notebook so the igpu has to be used since it’s the only one connected to the internal display. Currently, it’s using the fbdev fallback driver so nothing will work.
Please post the output of
grep -r nvidia /etc/modprobe.d/* /lib/modprobe.d/*

To upgrade to 5.3, download and install from here:
https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.3.8/
linux-headers-5.3.8-050308_5.3.8-050308.201910290940_all.deb
linux-headers-5.3.8-050308-generic_5.3.8-050308.201910290940_amd64.deb
linux-image-unsigned-5.3.8-050308-generic_5.3.8-050308.201910290940_amd64.deb
linux-modules-5.3.8-050308-generic_5.3.8-050308.201910290940_amd64.deb

The command you suggested reports:

/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/lib/modprobe.d/nvidia-kms.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/nvidia-kms.conf:options nvidia-drm modeset=1