NVidia Driver 415 not loaded on Ubuntu 18.04

I am having issue with loading my NVidia Drivers on my Ubuntu 18.04.
I’ve been looking around for this problem and have encountered similar issue which do have solution. None of these appear to have resolved the problem I have too.

Here some info on my machine:

  • OS is ‘Ubuntu 18.04.1 LTS’
    GT2)` onboard chip
  • I’m currently running nvidia-driver-415, but ran into similar problems with nvidia-driver 390, 396 and 410.
  • Output from lspci | grep VGA returns the following:
user@user:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
  • Output when I run nvidia-settings:
user@user:~$ nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:5260): GLib-GObject-CRITICAL **: 17:46:10.944: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 17:46:10.946: PRIME: Requires offloading
** Message: 17:46:10.946: PRIME: is it supported? yes
  • Output when I run xrandr:
user@user:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.02*+  60.01    59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1440x900      59.89  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      60.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32

Any guidance on what I could/should try out would be much appreciated. I am of course more than willing to provide additional information if necessary.

nvidia-bug-report.log.gz (89.7 KB)

How did you install the driver? Don’t use the .run installer since it’s an Optimus system. If you have installed the driver from Ubuntu’s repo or the graphics ppa then you should be able to switch to the Nvidia gpu using
sudo prime-select nvidia
and reboot. Otherwise, please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.

Thanks for your quick reply @generix!

Installing it via the .run installer is one of the things I’ve tried, with no avail though. So I reverted that operation.

sudo prime-select nvidia

one I’d encountered earlier, and also executed earlier, with the following result:

user@user:~$ sudo prime-select nvidia
Info: the nvidia profile is already set

Thus, I have followed your suggestion and created a bug report.
I has been added to the main post, I hope something useful turns up out of it!

Lastly, here is the output from running the script:

user@user:~$ sudo nvidia-bug-report.sh 

nvidia-bug-report.sh will now collect information about your
system and create the file 'nvidia-bug-report.log.gz' in the current
directory.  It may take several seconds to run.  In some
cases, it may hang trying to capture data generated dynamically
by the Linux kernel and/or the NVIDIA kernel module.  While
the bug report log file will be incomplete if this happens, it
may still contain enough data to diagnose your problem.

Please include the 'nvidia-bug-report.log.gz' log file when reporting
your bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to 'linux-bugs@nvidia.com'.

Running nvidia-bug-report.sh...ls: cannot access '/proc/driver/nvidia/./gpus/': No such file or directory

If the bug report script hangs after this point consider running with
--safe-mode and --extra-system-data command line arguments.


Should I be worried about the “cannot access ‘/proc/driver/nvidia/./gpus/’” message?

Please check if the file
exists and delete it, then run
sudo update-initramfs -u
and reboot.

I just checked whether


exists, but that’s not the case.
These are the files present under



user@user:~$ ll /lib/modprobe.d/
total 32
drwxr-xr-x  2 root root 4096 jan  3 11:07 ./
drwxr-xr-x 22 root root 4096 dec 20 09:47 ../
-rw-r--r--  1 root root  655 okt 24 01:20 aliases.conf
-rw-r--r--  1 root root 1461 nov 15 20:01 blacklist_linux_4.15.0-42-generic.conf
-rw-r--r--  1 root root 1461 dec  6 14:52 blacklist_linux_4.15.0-43-generic.conf
-rw-r--r--  1 root root  390 nov 15 21:45 fbdev-blacklist.conf
-rw-r--r--  1 root root  110 dec 20 09:44 nvidia-kms.conf
-rw-r--r--  1 root root  765 jan 28  2018 systemd.conf

Would it make sense to verify one of those files for peculiarities?

Ok, just noticed you have secure boot enabled so the driver doesn’t load since it isn’t signed. Just disable secure boot in bios.

Initially I disabled secure boot in the BIOS, but doing so removed my boot manager entirely.
What might be key in this situation, is that I have a dual boot set up, Windows 10 and Ubuntu 18.04, where Windows 10 was the distro the laptop came with.

As switching UEFI off in favor of the Legacy Mode made it so that I couldn’t start Windows 10 or Ubuntu 18.04, I followed method 2 as described here: https://wiki.ubuntu.com/UEFI/SecureBoot/DKMS
These seemed like a fair approach to disable Secure Boot.

After successfully following the steps there, I however am still left with Nvidia Drivers not being loaded, as can be seen here:

user@user:~$ nvidia-settings 

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:2893): GLib-GObject-CRITICAL **: 17:04:16.599: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 17:04:16.601: PRIME: Requires offloading
** Message: 17:04:16.601: PRIME: is it supported? yes

Is there something obvious I’ve missed from that wiki?

Might be that the kernel is still enforcing signed modules.
If secure boot cannot disabled for whatever reasons, the proper way would be to re-install Ubuntu and on installation, there should be an option “Install third party software” which leads to having a signed nvidia module that can be loaded without tinkering.

try also looking for sudo rm /lib/modprobe.d/blacklist-nvidia.conf or just grep all files in directory /lib/modprobe.d it did help me!

Hi @galvani78, thanks for your reply.
I however do not have a /lib/modprobe.d/blacklist-nvidia.conf file at the moment.
Would I do have in the /lib/modprobe.d/ folder, is the following:

  • aliases.conf
  • blacklist_linux_4.15.0-47-generic.conf
  • blacklist_linux_4.15.0-48-generic.conf
  • fbdev-blacklist.conf
  • nvidia-graphics-drivers.conf
  • nvidia-kms.conf
  • systemd.conf

Which of these would you expect to have to be removed?

Ow, and @generix, sorry to not be replying earlier.
I assumed your suggestion would solve the problem, but that would mean a reinstall of Ubuntu in that case.
That exact reinstall is what I had done just prior to posting this question, so I didn’t feel up to the task just yet… As soon as I get around to actually performing the reinstall and if it resolve the issue, I’ll accept your replies as the Answer.