Installed driver is not loading returning the message - ERROR: NVIDIA driver is not loaded


I have an HP OMEN Ryzen 7 4800 with a GeForce GTX 1660Ti running a dual boot with Windows 10 and Linux - Ubuntu 20.04.2 LTS with 5.8 kernel.

In Windows everything work with no problem.

In Linux however, the Nvidia drivers do not seem to load even though the card itself is recognized by the OS and the driver 450 is installed as well.

The main reason I need to get the card to work is to connect the laptop to an external display.

Please note that it is the first time I am using Linux and I use it strictly for a Data Science class where we are pretty much required to use Linux. Also, I can’t miss any classes so it is really important to be extremely cautious with everything I do.

I have spent lots of hours looking for a solution online so far, and even though I tried a few things nothing worked.



lspci -k | grep -A 2 -i "VGA" shows:

01:00.0 VGA compatible controller: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1)
DeviceName: NVIDIA Graphics Device
Subsystem: Hewlett-Packard Company TU116M [GeForce GTX 1660 Ti Mobile]

06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c6)
DeviceName: Onboard IGD
Subsystem: Hewlett-Packard Company Renoir

lshw -C video shows:

*-display UNCLAIMED
description: VGA compatible controller
product: TU116M [GeForce GTX 1660 Ti Mobile]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:fb000000-fbffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:f000(size=128) memory:fc000000-fc07ffff
description: VGA compatible controller
product: Renoir
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:06:00.0
version: c6
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: driver=amdgpu latency=0
resources: irq:51 memory:d0000000-dfffffff memory:e0000000-e01fffff ioport:c000(size=256) memory:fc500000-fc57ffff

nvidia-smi shows:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

nvidia-settings shows:

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:13322): GLib-GObject-CRITICAL **: 22:47:03.917: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 22:47:03.923: PRIME: No offloading required. Abort
** Message: 22:47:03.923: PRIME: is it supported? no

And also loads a blank NVIDIA X Server Settings tab.

dkms status shows:

nvidia, 450.102.04, 5.8.0-38-generic, x86_64: installed
nvidia, 450.102.04, 5.8.0-41-generic, x86_64: installed

Please note that Secure Boot is also enabled.

Lastly, I have attached the output of
nvidia-bug-report.log.gz (127.4 KB)

Sorry for the long post and thank you in advance for any help!

1 Like

Thanks for the quick reply, I did disable secure root and now it seems like the display port is recognized but it gives me a black screen. All the other things are the same.

Also the mini display port is recognized only when I connect it with the mini display port not the usb-c. But I don’t really care if it can connect via both. One is enough for me as long as it works properly. I mention it just fyi.

Should I purge and re install the drivers too?

Please create a new nvidia-bug-report.log

1 Like

Here it is:
nvidia-bug-report.log.gz (127.7 KB)


  • run
sudo prime-select nvidia
  • run
grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

blacklist nvidia

and remove it,
then run

sudo update-initramfs -u

and reboot.

1 Like

Great improvement, both HDMI and display port are detected, and are shown in Settings->Displays, but unfortunatelly the external display is still black. Any suggestions?

Please remove the blacklist file and run
sudo update-initramfs -u
and reboot to enable the nvidia driver again, then follow this:

I’m sorry, this was meant for another thread, so please ignore or revert if you made any changes.
Please create a new nvidia-bug-report.log.

1 Like

I just deleted the /etc/X11/xorg.conf.

As far as I know I cannot revert that. Am I wrong?

here is the new nvidia-bug-report.log:
nvidia-bug-report.log.gz (350.9 KB)

There’s no xorg.conf needed so if you had one, you needed to delete it anyway.
Please install the package nvidia-prime, then run
sudo prime-select nvidia
and reboot.

1 Like

The problem is still there unfortunately. External display is connected but the screen is black

I think nvidia-prime was already installed and also prime-select showed:

Info: the nvidia profile is already set

Also, if it helps, nvidia-settings show:

(nvidia-settings:5555): GLib-GObject-CRITICAL **: 11:03:24.466: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

ERROR: nvidia-settings could not find the registry key file. This file should
have been installed along with this driver at
/usr/share/nvidia/nvidia-application-profiles-key-documentation. The
application profiles will continue to work, but values cannot be
prepopulated or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions.

** Message: 11:03:24.570: PRIME: No offloading required. Abort
** Message: 11:03:24.570: PRIME: is it supported? no

The new
nvidia-bug-report.log.gz (326.5 KB)

and thank you very much once again for your time!

Please post the output of
dpkg -l |grep nvidia-prime
dpkg -l |grep ubuntu-drivers-common

Background is, AMD/Nvidia combos were first supported in Ubuntu 20.10 and the needed packages were just recently being backported to 20.04. Somehow, prime-select/gpu-manager don’t work correctly on your system, maybe the wrong versions are still installed. This can of course easily be circumvented manually but it’s better if the standard infrastructure works.

1 Like

dpkg -l |grep nvidia-prime:

ii nvidia-prime
all Tools to enable NVIDIA’s Prime

dpkg -l |grep ubuntu-drivers-common:

ii ubuntu-drivers-common 1:0.8.4~
amd64 Detect and install additional Ubuntu driver packages

I hope it is the correct output

nvidia-prime is the correct version but ubuntu-drivers-common needs to be at least v0.8.6 for amd ( being the current version)
Please check if you can upgrade
sudo apt update
sudo apt install ubuntu-drivers-common

1 Like

BINGO! Finally everything seems to work with no problem at all.

There are no words to express my gratitude for all your help, your super fast responses and your overall knowledge on the topic.

One last quick question though, with no intention to abuse your kindness.

I need my external display to work at least till end of march. Do you think that potential future updates can mess up my configuration? Should I avoid them for a while?

And same question about changing PRIME settings. Now it uses NVIDIA(Performance mode) which I do not mind since I am using my laptop plugged-in, but in case I want to switch to the AMD GPU or use NVIDIA on-demand do you think the external display will still work?

Thank you once again for everything, you are the man!

Since you’re on a Ubuntu LTS version with the latest HWE already, there shouldn’t be any breaking changes in future updates. Only HWE upgrades are sometimes bumpy.
Currently, external monitors can only be used when the nvidia gpu is primary with an AMD/Nvidia combo due to the output sink feature not being fully functional with amdgpu.

1 Like

Thanks a ton!