Black screen after install of nvidia driver ubuntu

I am trying to install nvidia-driver (440) on my Ubuntu on my laptop.

After a lot of failed attempts to install drivers properly I followed this instruction, which seemed good: https://askubuntu.com/questions/1050423/cannot-get-nvidia-graphics-card-to-work-on-ubuntu-18-04

Unfortunately, this doesn’t help. Even with the secure boot disabled I still got a black screen saying “/dev/sdb1: clean, 666666/14881488 files, 69696969/420420420 blocks” instead of normal lightdm user experience.

The interesting part is: nvidia-smi actually shows some output and driver seems to be running (I forgot to write it down before purging nvidia again, sorry).

Attached link to the nvidia-bug-report.sh output: https://drive.google.com/file/d/1NwsEw-yh2HPewAnjOyX_Y0Dj1fofCr8b/view?usp=sharing

I am on Ubuntu 19.10, kernel 5.3.0-24.
I have acer predator helios 300 series laptop with GTX 1060 (GP106M [GeForce GTX 1060 Mobile]) and Intel® Core™ i7-7700HQ CPU @ 2.80GHz processor.

Does anyone know how to fix this issue?

I forgot to mention: I have dual boot with Windows 10 (on the first SSD) and Ubuntu (on the second SSD). Grub and everything is on the second SSD and BIOS is configured to boot from there first.

Please follow this:

  • delete /etc/X11/xorg.conf
  • make sure nvidia-prime is installed (sudo apt install --reinstall nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot

Thanks, after completing the steps from the askubuntu thread (before reboot and skipping disable-nouveau part), I followed your instruction and now GUI seems to work fine.

I caught strange issue when I was spontaneously logged out. If it continues, I’ll create another thread for fixing the issue.

Getting spontaneous log-outs means the Xserver was crashing. Shouldn’t happen, so if it happens again please provide an nvidia-bug-report.log.

I have the same problem after install driver 440 :

nvidia-smi

Wed Apr 22 17:35:57 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82 Driver Version: 440.82 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce RTX 2060 Off | 00000000:01:00.0 Off | N/A |
| 50% 41C P0 24W / 170W | 0MiB / 5933MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

I can use putty, but my server screen is black, I can no longer use it.

sudo apt purge nvidia*
sudo apt autoremove --purge
sudo apt update && sudo apt full-upgrade

It’s OK I have my screen but after :

sudo ubuntu-drivers autoinstall

…Same problem

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Ok thanks, I send my Log File.

nvidia-bug-report.log (795.1 KB)

Unfortunately, no config or Xorg log files included. Please run
find /etc/X11 /etc/X11/xorg.conf.d /usr/share/X11/xorg.conf.d -name "*.conf" -print -exec cat '{}' \; >allconfig.txt
and
sudo journalctl -b0 |grep “gdm-x-session” >gdm.log
and attach both output files.
Furthermore, you have also an intel gpu, which gpu is the monitor connected to?

I’m sending you the Xorg journal, it’s a server version so I don’t have a gdm-session. The screen is connected to the RTX2060 card, the server startup appears on the screen, it is at the command prompt that I have a black screen.

allconfig.log (7.0 KB)

Ok, so you don’t run any xsession, just text console?
Please try setting the kernel parameter
nomodeset
to keep the intel driver from loading. if that doesn’t help, check if you can disable the igpu in bios.

Congratulation.

sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="debian-installer/language=fr keyboard-configuration/layoutcode?=fr keyboard-configuration/variantcode?=oss nomodeset"
sudo update-grub
sudo reboot

and it’s ok…ok next stape thanks a lot !

I will have to use the card with tensorflow, some have chosen me said that arriving at this stage I will come back to see you ahahahah

Hello!

I have the similar issue on lenovo legion laptop.
After login the black screen with Legion logo.
Wed May 6 15:00:50 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.59 Driver Version: 440.59 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 166… Off | 00000000:01:00.0 On | N/A |
| N/A 46C P5 11W / N/A | 268MiB / 5936MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1484 G /usr/bin/gnome-shell 215MiB |
| 0 2037 G /usr/lib/xorg/Xorg 8MiB |
±----------------------------------------------------------------------------+

I’ve tried to set nomodeset. The result is the same

will be appreciated for the helpnvidia-bug-report.log (269.0 KB)

Please remove the kernel parameter ‘nomodeset’, then run

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

options nvidia-drm modeset=1

and change 1 to 0
then run

sudo update-initramfs -u

and reboot.

Thank you very much. Now it works.

I have similar issue on MSI laptop WP65 with above.
After installing nvidia-440, i can’t boot just black screen with cursor.
here I attach the log file.
nvidia-bug-report.log (234.2 KB)

Please remove ‘nomodeset’ kernel parameter.

Thank you, that solved my problem.
But I have another issue of crashing on resume after suspend related to nvidia.
May I ask you to resolve this issue?
I attach the crash log.

Please try kernel parameters
acpi_osi=! acpi_osi=“Windows 2009”

Hello, i’m facing the same problem

GTX 1660 ti

I installed Ubuntu 20 or Linux Mint 20 and both do not start x, only with safe mode.
So I tried to install driver from file and do not work.

nvidia-bug-report.log (689.9 KB)

Can someone help me?