Ubuntu MATE 20.04 with RTX 3070 on Ryzen 5900 - black screen after boot

Basically the title says it all.
I have brand new Asus Rog Strix with AMD Ryzen 9 and Nvidia RTX 3070.
After the initial install of Ubuntu MATE 20.04 it is working fine with the Nouveau driver. However, if I install the nvidia driver (manually or via the package manager), I always end-up on black screen after reboot. Tried every solution I have found, but nothing works. At least I am able to get in the console and generate bug report.

nvidia-bug-report.log.gz (259.2 KB)

Any help will be much appreciated.
Thanks.

Your kernel is too old for the amd gpu. Please upgrade your hwe
https://wiki.ubuntu.com/Kernel/LTSEnablementStack and do a full system update afterwards. This should give you the neccessary kernel and driver versions.

1 Like

Hey, @generix , thanks for your response. I did a clean install of ubuntu mate 20.04.02, which uses kernel 5.8.0-41, but still no luck. Exactly the same issue. Attaching the new bug report

nvidia-bug-report.log.gz (279.3 KB)

Also, I noticed that the laptop display is not recognized and runs only on 77 Hz

Please remove the ‘nomodeset’ kernel parameter.

1 Like

Hey, @generix , I already tried that, but tried it again - same thing.
Attaching bug report without nomodeset

nvidia-bug-report.log.gz (290.4 KB)

You have a driver mismatch
Feb 6 08:47:48 predte4a-dev kernel: [ 4.238258] NVRM: API mismatch: the client has the version 460.39, but
Feb 6 08:47:48 predte4a-dev kernel: [ 4.238258] NVRM: this kernel module has the version 460.32.03. Please
Feb 6 08:47:48 predte4a-dev kernel: [ 4.238258] NVRM: make sure that this kernel module and all NVIDIA driver
Feb 6 08:47:48 predte4a-dev kernel: [ 4.238258] NVRM: components have the same version.
Please purge and reinstall the driver.

1 Like

Hey, @generix , thank you very much for your time, but I`m really confused right now. If I do
“ubuntu-drivers list”
I get
“nvidia-driver-460, (kernel modules provided by linux-modules-nvidia-460-generic-hwe-20.04)”

However, If I do
“sudo apt install --install-recommends linux-modules-nvidia-460-generic-hwe-20.04”

I get:
The following packages have unmet dependencies:
linux-modules-nvidia-460-generic-hwe-20.04 : Depends: nvidia-kernel-common-460 (<= 460.32.03-1) but 460.39-0ubuntu0.20.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

So I have to install
linux-modules-nvidia-460-5.8.0-41-generic, cause this looks like the right modules for my kernel. But if I do so you say there is a driver mismatch… frustrating stuff…
In the repo I see only one package about 460 and it is nvidia-kernel-common-460. If I install it it turns out to be:
Unpacking nvidia-kernel-common-460 (460.39-0ubuntu0.20.04.1)

What should I install after all and is there some documentation about this thing?

You’re trying to install specific sub-packages which don’t fit to your system.
Please uninstall the driver, while inside an empty directory:

sudo apt remove nvidia*
sudo apt remove libnvidia*

according to the logs, you still have ‘nomodeset’ set, please make sure it is removed from grub config and run

sudo update-grub

then reboot. After reboot, please check if Ubuntu system info reports
“AMD Renoir”
as graphics device.
If that’s the case, you can use Software&Updates to install the nvidia driver.

1 Like

Hey, @generix ,
Ubuntu shows that the packages you mentioned are already unistalled. I updated the grub, but the graphics used are
“lvmpipe (LLVM 11.0.0, 256 bits)”

I’m sorry, I only now saw that you’re on a brand-new Ryzen 5900, those are only supported by kernel 5.10+. You’ll have to install that manually:
You will need 4 packages
linux-headers-XX
linux-headers-XX-generic
linux-image-unsigned-XX-generic
linux-modules-XX-generic
from https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.10.14/
Afterwards, please check if the correct AMD graphics is displayed

1 Like

@predte4a, did you solve it? I have the same Asus (Ryzen 5900, RTX 3070 mobile) with the same issue.
When I tried kernel 5.10.14 with 460.39 a screen was black, I heard login screen loaded sound, but no picture at all.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

1 Like

@sano1982 , no luck for me yet. It looks like we both have exactly the same issue.
@generix , I installed 5.10.14 kernel, but when I boot I get error:

nouveau 0000:01:00.0: unknown chipset (b74000a1)

and the boot hangs.
If I put “nomodeset” to the kernel parameters the OS starts normally, but again it is using
“Graphics: lvmpipe (LLVM 11.0.0, 256 bits)”

Can you switch to a vt using ctrl+alt+f4 when the boot hangs? You could then create a kernel log using
sudo dmesg > kernel.txt
Alternatively, boot to hang, reboot setting ‘nomodeset’ parameter and run
sudo journalctl -b-1 --no-pager |grep kernel >kernel.txt
and attach kernel.txt. Maybe some firmware files are missing/incorrect.

1 Like

Hey, @generix , when the PC hangs on boot it is not responding, so ctrl+alt+f4 is not possible.
However, I got into recovery mode and here is the result of “sudo journalctl -b-1 --no-pager |grep kernel >kernel.txt”

kernel.txt (106.5 KB)

Ok, the amd firmware is missing. AFAIK, the gpu of the 5xxx series will be called Cezanne, a descendant of the 4xxx Renoir gpu. Currently, it has the codename “Green Sardine” so the driver tries to load green_sardine firmware. Which has not been publicly released by lazy AMD (the driver was added back in october).
So it’s now hunting for the firmware files.

1 Like

https://people.freedesktop.org/~agd5f/radeon_ucode/gs/
Those should be the files. Please download all of them and copy to /lib/firmware/amdgpu

1 Like

Hey, @generix ,
No luck yet. I have added these files to /lib/firmware/amdgpu.
I made sure they have the same owner and permissions as the other files in the dir.
However, without nomodest to the kernel again it hangs with

nouveau 0000:01:00.0: unknown chipset (b74000a1)

With nomodest it boots, but again it is using

“Graphics: lvmpipe (LLVM 11.0.0, 256 bits)”

Here is the new kernel log:
new_kernel.txt (106.4 KB)

Please try running
sudo update-initramfs -u
to embed the files in the initrd.

1 Like

Hey, @generix ,
Looks like it works now:
Graphics: AMD RENOIR (DRM 3.40.0, 5.10.14-051014-generic, LLVM 11.0.1)

Should I just have to install the NVIDIA driver now?